aboutsummaryrefslogtreecommitdiff
path: root/www/mod_python35
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-04-16 22:31:32 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-04-16 22:31:32 +0000
commitf9e7438289501246a995a90d1c191b32f981cb74 (patch)
tree20141268b1598f622c75e1caadcde56da28fb082 /www/mod_python35
parentb8856298ff8a2111bfe5a205c55f5a805753e401 (diff)
downloadports-f9e7438289501246a995a90d1c191b32f981cb74.tar.gz
ports-f9e7438289501246a995a90d1c191b32f981cb74.zip
Notes
Diffstat (limited to 'www/mod_python35')
-rw-r--r--www/mod_python35/Makefile6
-rw-r--r--www/mod_python35/pkg-plist6
2 files changed, 9 insertions, 3 deletions
diff --git a/www/mod_python35/Makefile b/www/mod_python35/Makefile
index 123a854d87af..8cdb3cafe8c3 100644
--- a/www/mod_python35/Makefile
+++ b/www/mod_python35/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mod_python
PORTVERSION= 3.5.0
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= http://dist.modpython.org/dist/ \
LOCAL/ohauer
@@ -16,11 +17,12 @@ COMMENT= Apache module that embeds the Python interpreter within the server
LICENSE= APACHE20
+CONFLICTS_INSTALL= ap2[24]-mod_python3[^5]*
+
USE_APACHE= 22+
USE_PYTHON= yes
USES= tar:tgz
-INSTALLS_EGGINFO= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs="${APXS}" \
--with-python="${PYTHON_CMD}" \
@@ -29,6 +31,8 @@ CONFIGURE_ARGS+= --with-apxs="${APXS}" \
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS+= APXS=${APXS}
MAKE_ENV= EXPR_COMPAT=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} \
+ PYTHON_VER=${PYTHON_VER}
# You need to install apache & mod_python before you run this
regression-test: build
diff --git a/www/mod_python35/pkg-plist b/www/mod_python35/pkg-plist
index faf780c862fb..84d719d8582b 100644
--- a/www/mod_python35/pkg-plist
+++ b/www/mod_python35/pkg-plist
@@ -1,4 +1,5 @@
bin/mod_python
+%%PYTHON_SITELIBDIR%%/mod_python-%%PORTVERSION%%-py%%PYTHON_VER%%.egg-info
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.py
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.pyc
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.pyo
@@ -42,7 +43,8 @@ bin/mod_python
%%PYTHON_SITELIBDIR%%/mod_python/wsgi.py
%%PYTHON_SITELIBDIR%%/mod_python/wsgi.pyc
%%PYTHON_SITELIBDIR%%/mod_python/wsgi.pyo
+@unexec /usr/bin/sed -i '' '/LoadModule %%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
%%APACHEMODDIR%%/%%AP_MODULE%%
-@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
-@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
+@exec %D/sbin/apxs -e %%AP_MOD_EN%% -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all mod_%%AP_NAME%%-related directives in your httpd.conf"
@dirrm %%PYTHON_SITELIBDIR%%/mod_python