aboutsummaryrefslogtreecommitdiff
path: root/www/mod_python3
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-09 01:12:10 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-06-09 01:12:10 +0000
commit5cc76d5a23bd6813f9a80a5b2450c508565b9d4e (patch)
tree14d2c7a48c61aac171f95125a9dc3d21b1826557 /www/mod_python3
parent37a9daa188011e425f25b368fe250cdc40d3ceea (diff)
downloadports-5cc76d5a23bd6813f9a80a5b2450c508565b9d4e.tar.gz
ports-5cc76d5a23bd6813f9a80a5b2450c508565b9d4e.zip
Notes
Diffstat (limited to 'www/mod_python3')
-rw-r--r--www/mod_python3/Makefile4
-rw-r--r--www/mod_python3/files/patch-Makefile.in10
-rw-r--r--www/mod_python3/pkg-plist4
3 files changed, 15 insertions, 3 deletions
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index 3a9d47cb46fa..a7d76f318225 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_python
PORTVERSION= 3.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
@@ -22,6 +22,8 @@ MAKE_JOBS_SAFE= yes
USE_APACHE= 2.2+
USE_PYTHON= yes
+MAKE_ARGS+= APXS=${APXS}
+
INSTALLS_EGGINFO= yes
LATEST_LINK= mod_python3
GNU_CONFIGURE= yes
diff --git a/www/mod_python3/files/patch-Makefile.in b/www/mod_python3/files/patch-Makefile.in
new file mode 100644
index 000000000000..bde1f5bc7fff
--- /dev/null
+++ b/www/mod_python3/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- ./Makefile.in.orig 2010-06-08 21:02:59.711010209 -0400
++++ ./Makefile.in 2010-06-08 21:06:55.645681728 -0400
+@@ -61,6 +61,7 @@
+ @echo
+ $(INSTALL) -d $(DESTDIR)$(LIBEXECDIR)
+ $(INSTALL) src/mod_python.so $(DESTDIR)$(LIBEXECDIR)
++ ${APXS} -e -a -n python $(DESTDIR)$(LIBEXECDIR)/mod_python.so
+ @echo
+ @echo "Now don't forget to edit your main config and add"
+ @echo " LoadModule python_module $(LIBEXECDIR)/mod_python.so"
diff --git a/www/mod_python3/pkg-plist b/www/mod_python3/pkg-plist
index 18285f5fcdef..0421c24d2256 100644
--- a/www/mod_python3/pkg-plist
+++ b/www/mod_python3/pkg-plist
@@ -1,6 +1,6 @@
%%APACHEMODDIR%%/%%AP_MODULE%%
-@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %f
-@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %f
+@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
+@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.py
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.pyc
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.pyo