aboutsummaryrefslogtreecommitdiff
path: root/www/mod_python3
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-24 13:50:56 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-24 13:50:56 +0000
commite42eab0e2510b003cf8e4711b2842b20a1974981 (patch)
tree720ef4a5b07549af1481cb1bd436d2587c2f9c7e /www/mod_python3
parentb35f3a5c1e9f5ae7da5c2c69611b52c1ea088f93 (diff)
downloadports-e42eab0e2510b003cf8e4711b2842b20a1974981.tar.gz
ports-e42eab0e2510b003cf8e4711b2842b20a1974981.zip
Notes
Diffstat (limited to 'www/mod_python3')
-rw-r--r--www/mod_python3/Makefile2
-rw-r--r--www/mod_python3/files/patch-src__connobject.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index 8bd6e9da76ce..25f1c8cd28c8 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Apache module that embeds the Python interpreter within the server
USE_APACHE= 2.0+
diff --git a/www/mod_python3/files/patch-src__connobject.c b/www/mod_python3/files/patch-src__connobject.c
new file mode 100644
index 000000000000..cfb1e34b82a3
--- /dev/null
+++ b/www/mod_python3/files/patch-src__connobject.c
@@ -0,0 +1,18 @@
+Index: files/patch-src__connobject.c
+===================================================================
+RCS file: files/patch-src__connobject.c
+diff -N files/patch-src__connobject.c
+--- /dev/null 1 Jan 1970 00:00:00 -0000
++++ files/patch-src__connobject.c 10 Jul 2008 20:08:25 -0000
+@@ -0,0 +1,11 @@
++--- ./src/connobject.c.orig 2008-07-10 19:57:53.000000000 +0000
+++++ ./src/connobject.c 2008-07-10 19:57:18.000000000 +0000
++@@ -139,7 +139,7 @@
++ bytes_read = 0;
++
++ while ((bytes_read < len || len == 0) &&
++- !(b == APR_BRIGADE_SENTINEL(b) ||
+++ !(b == APR_BRIGADE_SENTINEL(bb) ||
++ APR_BUCKET_IS_EOS(b) || APR_BUCKET_IS_FLUSH(b))) {
++
++ const char *data;