aboutsummaryrefslogtreecommitdiff
path: root/www/netstiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-23 00:02:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-23 00:02:24 +0000
commit571042ffb0d2bf6fc81d544dac235683f5ddb480 (patch)
tree05f295f5a09ba78dcd7b71f59bba873e031dbe05 /www/netstiff
parent516b5345a51a7db227ba43f825f5e1e3e17fcb14 (diff)
downloadports-571042ffb0d2bf6fc81d544dac235683f5ddb480.tar.gz
ports-571042ffb0d2bf6fc81d544dac235683f5ddb480.zip
Notes
Diffstat (limited to 'www/netstiff')
-rw-r--r--www/netstiff/Makefile32
-rw-r--r--www/netstiff/distinfo3
-rw-r--r--www/netstiff/pkg-descr6
3 files changed, 41 insertions, 0 deletions
diff --git a/www/netstiff/Makefile b/www/netstiff/Makefile
new file mode 100644
index 000000000000..df1726f7001b
--- /dev/null
+++ b/www/netstiff/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: netstiff
+# Date created: 23 March 2007
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netstiff
+PORTVERSION= 20070322
+CATEGORIES= www
+MASTER_SITES= http://pkqs.net/~sbeyer/tools/netstiff/
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A powerful web page update checker
+
+NO_BUILD= yes
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/ruby|${RUBY}|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/www/netstiff/distinfo b/www/netstiff/distinfo
new file mode 100644
index 000000000000..d4923d683a29
--- /dev/null
+++ b/www/netstiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (netstiff_20070322.orig.tar.gz) = b922ae860192a9689d216d1467dbc42d
+SHA256 (netstiff_20070322.orig.tar.gz) = 20d30bd2abdf0edad105700e88e9b7fa5375d50e14f40f034ccf2f29a06baedf
+SIZE (netstiff_20070322.orig.tar.gz) = 13609
diff --git a/www/netstiff/pkg-descr b/www/netstiff/pkg-descr
new file mode 100644
index 000000000000..5d3917e82c31
--- /dev/null
+++ b/www/netstiff/pkg-descr
@@ -0,0 +1,6 @@
+netstiff (formerly known as webdiff) is a powerful Web page update checker.
+It supports a variety of different methods (diff, html, size, date, MD5 sum,
+regexp) and only prints the URIs of the Web pages that changed so that its
+output can easily be used by other scripts (such as wget or mail).
+
+WWW: http://pkqs.net/~sbeyer/#netstiff