aboutsummaryrefslogtreecommitdiff
path: root/www/nghttp2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-19 23:26:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-19 23:26:15 +0000
commitc8f0ff3bed49812b41a93f19a412c633b92e2579 (patch)
tree6062d3c48f899ea44efaa076fc0c2624275c8a0c /www/nghttp2
parent0c31ee6900d391f0913c8dffd5a3046ae66ad1d5 (diff)
downloadports-c8f0ff3bed49812b41a93f19a412c633b92e2579.tar.gz
ports-c8f0ff3bed49812b41a93f19a412c633b92e2579.zip
Move upstream patch to files directory
Notes
Notes: svn path=/head/; revision=499399
Diffstat (limited to 'www/nghttp2')
-rw-r--r--www/nghttp2/Makefile3
-rw-r--r--www/nghttp2/files/patch-src-asio_server_connection.h35
2 files changed, 35 insertions, 3 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index fafd9e2191a6..2ce237292d07 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -6,9 +6,6 @@ PORTVERSION= 1.38.0
DISTVERSIONPREFIX= v
CATEGORIES= www net
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= cbba1ebf8fce.patch:-p1
-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= HTTP/2.0 C Library
diff --git a/www/nghttp2/files/patch-src-asio_server_connection.h b/www/nghttp2/files/patch-src-asio_server_connection.h
new file mode 100644
index 000000000000..cb5336a9fce0
--- /dev/null
+++ b/www/nghttp2/files/patch-src-asio_server_connection.h
@@ -0,0 +1,35 @@
+Obtained from: https://github.com/nghttp2/nghttp2/commit/cbba1ebf8fcecb24392f0cc07b1235b17d0de9d8
+
+--- src/asio_server_connection.h.orig 2019-04-18 06:08:36 UTC
++++ src/asio_server_connection.h
+@@ -51,6 +51,12 @@
+ #include "util.h"
+ #include "template.h"
+
++#if BOOST_VERSION >= 107000
++#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
++#else
++#define GET_IO_SERVICE(s) ((s).get_io_service())
++#endif
++
+ namespace nghttp2 {
+
+ namespace asio_http2 {
+@@ -71,7 +77,7 @@ public:
+ SocketArgs &&... args)
+ : socket_(std::forward<SocketArgs>(args)...),
+ mux_(mux),
+- deadline_(socket_.get_io_service()),
++ deadline_(GET_IO_SERVICE(socket_)),
+ tls_handshake_timeout_(tls_handshake_timeout),
+ read_timeout_(read_timeout),
+ writing_(false),
+@@ -82,7 +88,7 @@ public:
+ boost::system::error_code ec;
+
+ handler_ = std::make_shared<http2_handler>(
+- socket_.get_io_service(), socket_.lowest_layer().remote_endpoint(ec),
++ GET_IO_SERVICE(socket_), socket_.lowest_layer().remote_endpoint(ec),
+ [this]() { do_write(); }, mux_);
+ if (handler_->start() != 0) {
+ stop();