aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2008-10-22 07:36:57 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2008-10-22 07:36:57 +0000
commit60509b36188c77f6262bdbe2bacfc96f5954f21f (patch)
treea20d6010e5e44f7ee7de741333c719b0174c76f6 /www/nginx-devel/Makefile
parent7c1d31f2aad27b822d80c492b1b55fbc3bbfc46e (diff)
Notes
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index a72534f7b985..be4105c496a5 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -26,6 +26,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_PERL_MODULE "Enable http_perl module" off \
HTTP_RANDOM_INDEX_MODULE "Enable http_random_index module" off \
HTTP_REALIP_MODULE "Enable http_realip module" off \
+ HTTP_RESPONSE_MODULE "Enable http_response module" off \
HTTP_REWRITE_MODULE "Enable http_rewrite module" on \
HTTP_SECURE_LINK_MODULE "Enable http_secure_link module" off \
HTTP_SSL_MODULE "Enable http_ssl module" off \
@@ -112,6 +113,14 @@ CONFIGURE_ARGS+=--with-http_random_index_module
CONFIGURE_ARGS+=--with-http_realip_module
.endif
+.if defined(WITH_HTTP_RESPONSE_MODULE)
+NGINX_RESPONSE_MODULE_VERSION= 0.1
+PATCH_SITES+= http://catap.ru/patches/nginx/:response
+PATCHFILES+= ngx_http_response_module-${NGINX_RESPONSE_MODULE_VERSION}.dpatch:response
+PATCH_DIST_STRIP= -p1
+CONFIGURE_ARGS+=--with-http_response_module
+.endif
+
.if defined(WITH_HTTP_SECURE_LINK_MODULE)
CONFIGURE_ARGS+=--with-http_secure_link_module
.endif