aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2017-05-03 22:33:19 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2017-05-03 22:33:19 +0000
commitc5feee3b45bd5cb538b3f22e7c3f6a7bd3c228f0 (patch)
tree77611f571849eb1aadb40e935b83ec7cb33e7535 /www/nginx-devel/Makefile
parenta36274b826d0cb9c9b2d3b927f59011c9397b63e (diff)
downloadports-c5feee3b45bd5cb538b3f22e7c3f6a7bd3c228f0.tar.gz
ports-c5feee3b45bd5cb538b3f22e7c3f6a7bd3c228f0.zip
Notes
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index fe739f660da3..a02bbff42da4 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -377,10 +377,15 @@ USE_OPENLDAP= yes
.endif
.if ${PORT_OPTIONS:MHTTP_AUTH_PAM}
-NGINX_AUTH_PAM_VERSION= 1.2
-MASTER_SITES+= http://web.iti.upv.es/~sto/nginx/:auth_pam
-DISTFILES+= ngx_http_auth_pam_module-${NGINX_AUTH_PAM_VERSION}.tar.gz:auth_pam
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_auth_pam_module-${NGINX_AUTH_PAM_VERSION}
+GIT_HTTP_AUTH_PAM_VERSION= 1.5.1
+GH_ACCOUNT+= sto:auth_pam
+GH_PROJECT+= ngx_http_auth_pam_module:auth_pam
+GH_TAGNAME+= v${GIT_HTTP_AUTH_PAM_VERSION}:auth_pam
+.if !empty(PORT_OPTIONS:MDSO)
+CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_auth_pam}
+.else
+CONFIGURE_ARGS+=--add-module=${WRKSRC_auth_pam}
+.endif
.endif
.if ${PORT_OPTIONS:MHTTP_AUTH_REQ}