aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2020-12-15 15:04:15 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2020-12-15 15:04:15 +0000
commit769c5625658bb8b3a158c9739506417cfb6ba7cd (patch)
treeb5c87e7439d067f405c67e097318a496cf58d4e6 /www/nginx-devel
parentaa1634ec212b89284d1f1e3cb12fcbee2a93e955 (diff)
downloadports-769c5625658bb8b3a158c9739506417cfb6ba7cd.tar.gz
ports-769c5625658bb8b3a158c9739506417cfb6ba7cd.zip
Update from 1.19.5 to 1.19.6.
<Changelog> *) Bugfix: "no live upstreams" errors if a "server" inside "upstream" block was marked as "down". *) Bugfix: a segmentation fault might occur in a worker process if HTTPS was used; the bug had appeared in 1.19.5. *) Bugfix: nginx returned the 400 response on requests like "GET http://example.com?args HTTP/1.0". *) Bugfix: in the ngx_http_flv_module and ngx_http_mp4_module. Thanks to Chris Newton. </Changelog>
Notes
Notes: svn path=/head/; revision=558162
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile5
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/PR-251664.patch72
3 files changed, 4 insertions, 79 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index dc4093596229..152b5407ed1c 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -2,16 +2,13 @@
# $FreeBSD$
PORTNAME?= nginx
-PORTVERSION= 1.19.5
-PORTREVISION= 4
+PORTVERSION= 1.19.6
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
PKGNAMESUFFIX?= -devel
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
-EXTRA_PATCHES+= ${FILESDIR}/PR-251664.patch:-p1
-
MAINTAINER?= osa@FreeBSD.org
COMMENT?= Robust and small WWW server
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 22cee455a087..9db4d08088f2 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1606839346
-SHA256 (nginx-1.19.5.tar.gz) = 5c0a46afd6c452d4443f6ec0767f4d5c3e7c499e55a60cd6542b35a61eda799c
-SIZE (nginx-1.19.5.tar.gz) = 1055590
+TIMESTAMP = 1608043808
+SHA256 (nginx-1.19.6.tar.gz) = b11195a02b1d3285ddf2987e02c6b6d28df41bb1b1dd25f33542848ef4fc33b5
+SIZE (nginx-1.19.6.tar.gz) = 1055982
SHA256 (nginx_mogilefs_module-1.0.4.tar.gz) = 7ac230d30907f013dff8d435a118619ea6168aa3714dba62c6962d350c6295ae
SIZE (nginx_mogilefs_module-1.0.4.tar.gz) = 11208
SHA256 (nginx_mod_h264_streaming-2.2.7.tar.gz) = 6d974ba630cef59de1f60996c66b401264a345d25988a76037c2856cec756c19
diff --git a/www/nginx-devel/files/PR-251664.patch b/www/nginx-devel/files/PR-251664.patch
deleted file mode 100644
index 4950eed12895..000000000000
--- a/www/nginx-devel/files/PR-251664.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-# HG changeset patch
-# User Ruslan Ermilov <ru@nginx.com>
-# Date 1607367150 -10800
-# Mon Dec 07 21:52:30 2020 +0300
-# Node ID 9cad062c593037ada10c2e50ff503a4d4ce19a8f
-# Parent 2522d789afbaa1d79105a08c35c46e52984cee68
-SSL: fixed SSL shutdown on lingering close.
-
-Ensure c->recv is properly reset to ngx_recv if SSL_shutdown()
-blocks on writing.
-
-The bug had appeared in 554c6ae25ffc.
-
-diff --git a/src/event/ngx_event_openssl.c b/src/event/ngx_event_openssl.c
---- a/src/event/ngx_event_openssl.c
-+++ b/src/event/ngx_event_openssl.c
-@@ -2880,6 +2880,7 @@ ngx_ssl_shutdown(ngx_connection_t *c)
-
- SSL_free(c->ssl->connection);
- c->ssl = NULL;
-+ c->recv = ngx_recv;
-
- return NGX_OK;
- }
-@@ -2925,6 +2926,7 @@ ngx_ssl_shutdown(ngx_connection_t *c)
- if (n == 1) {
- SSL_free(c->ssl->connection);
- c->ssl = NULL;
-+ c->recv = ngx_recv;
-
- return NGX_OK;
- }
-@@ -2967,6 +2969,7 @@ ngx_ssl_shutdown(ngx_connection_t *c)
- if (sslerr == SSL_ERROR_ZERO_RETURN || ERR_peek_error() == 0) {
- SSL_free(c->ssl->connection);
- c->ssl = NULL;
-+ c->recv = ngx_recv;
-
- return NGX_OK;
- }
-@@ -2977,6 +2980,7 @@ ngx_ssl_shutdown(ngx_connection_t *c)
-
- SSL_free(c->ssl->connection);
- c->ssl = NULL;
-+ c->recv = ngx_recv;
-
- return NGX_ERROR;
- }
-diff --git a/src/http/ngx_http_request.c b/src/http/ngx_http_request.c
---- a/src/http/ngx_http_request.c
-+++ b/src/http/ngx_http_request.c
-@@ -3397,8 +3397,6 @@ ngx_http_set_lingering_close(ngx_connect
- c->ssl->handler = ngx_http_set_lingering_close;
- return;
- }
--
-- c->recv = ngx_recv;
- }
- #endif
-
-diff --git a/src/http/v2/ngx_http_v2.c b/src/http/v2/ngx_http_v2.c
---- a/src/http/v2/ngx_http_v2.c
-+++ b/src/http/v2/ngx_http_v2.c
-@@ -739,8 +739,6 @@ ngx_http_v2_lingering_close(ngx_connecti
- c->ssl->handler = ngx_http_v2_lingering_close;
- return;
- }
--
-- c->recv = ngx_recv;
- }
- #endif
-