aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2014-06-02 02:14:54 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2014-06-02 02:14:54 +0000
commit064f791af40630433d67afb9953eb58d7971e783 (patch)
tree833b6828bb46f3d26c4fd6d1ad031d1a71e73904 /www/nginx
parentc4bf2a232e706f0bebd7338097555bb8e44e908b (diff)
downloadports-064f791af40630433d67afb9953eb58d7971e783.tar.gz
ports-064f791af40630433d67afb9953eb58d7971e783.zip
Notes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-passenger-build-nginx.rb10
3 files changed, 9 insertions, 7 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 72dbf486690e..a2cf9647f7ee 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -648,7 +648,7 @@ CONFIGURE_ARGS+=--without-http_rewrite_module \
.endif
.if ${PORT_OPTIONS:MPASSENGER}
-PASSENGER_VERSION= 4.0.41
+PASSENGER_VERSION= 4.0.44
MASTER_SITES+= http://s3.amazonaws.com/phusion-passenger/releases/:passenger
DISTFILES+= passenger-${PASSENGER_VERSION}.tar.gz:passenger
CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 698ce53a004e..29ae58464007 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -74,8 +74,8 @@ SHA256 (modsecurity-apache_2.7.5.tar.gz) = 9e907536278d8da80d3dbb29aeffe9c4ec37c
SIZE (modsecurity-apache_2.7.5.tar.gz) = 1045387
SHA256 (naxsi-core-0.50.tgz) = 7cece5f9d9c5df9e09af1e1023bc8e04bbbbe953e67461b893b8240e82ca52ef
SIZE (naxsi-core-0.50.tgz) = 49809
-SHA256 (passenger-4.0.41.tar.gz) = 7b1857e02280066d4be9123a1c13ead1eba280e60e3eba7b4f0e16279fd71259
-SIZE (passenger-4.0.41.tar.gz) = 4060645
+SHA256 (passenger-4.0.44.tar.gz) = 201308c9d95ccbd7aa5167a22bdc4e403f90ba7a185d5cc51a840caa0c3cd30e
+SIZE (passenger-4.0.44.tar.gz) = 3928963
SHA256 (ngx_postgres-0.9.tar.gz) = aac0141e73b5c440927b7e040072f120b36e49deb2ff36ad00ff96a80622fbec
SIZE (ngx_postgres-0.9.tar.gz) = 41022
SHA256 (agentzh-rds-csv-nginx-module-v0.05-0-g607e26b.tar.gz) = 3fa9cb3960a97f505c9ad0cc8683c8fe17ba98aa98d003e255bf214e5144751c
diff --git a/www/nginx/files/extra-patch-passenger-build-nginx.rb b/www/nginx/files/extra-patch-passenger-build-nginx.rb
index 8034a07e5f7d..ebd3a7e49813 100644
--- a/www/nginx/files/extra-patch-passenger-build-nginx.rb
+++ b/www/nginx/files/extra-patch-passenger-build-nginx.rb
@@ -1,13 +1,15 @@
---- ../passenger-4.0.41/build/nginx.rb.orig 2013-10-12 11:05:08.000000000 +0400
-+++ ../passenger-4.0.41/build/nginx.rb 2013-10-12 11:06:18.000000000 +0400
-@@ -32,16 +32,12 @@
+--- ../passenger-4.0.44/build/nginx.rb.orig 2013-10-27 02:00:00.000000000 +0400
++++ ../passenger-4.0.44/build/nginx.rb 2014-06-02 05:55:12.000000000 +0400
+@@ -32,6 +32,7 @@
desc "Build Nginx support files"
task :nginx => [
:nginx_without_native_support,
-+ LIBBOOST_OXT,
++ LIBBOOST_OXT,
NATIVE_SUPPORT_TARGET
].compact
+@@ -40,11 +41,6 @@
+
task :nginx_without_native_support => [
auto_generated_sources,
- AGENT_OUTPUT_DIR + 'PassengerHelperAgent',