aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2024-03-11 11:30:53 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2024-03-11 11:32:34 +0000
commit1909da24200c5e089128880d453a26e3253d8b65 (patch)
tree53badc6bac554f96c7de289d4b1ddac9e7adf117 /www/nginx
parent0a4b014023be20628a10fecab22876bdb1bee7d9 (diff)
downloadports-1909da24200c5e089128880d453a26e3253d8b65.tar.gz
ports-1909da24200c5e089128880d453a26e3253d8b65.zip
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/Makefile.extmod11
-rw-r--r--www/nginx/Makefile.options.desc1
-rw-r--r--www/nginx/files/extra-patch-nginx-opentracing-opentracing-config8
-rw-r--r--www/nginx/pkg-plist1
5 files changed, 4 insertions, 19 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 3e431ec495d9..4d92fc92c11e 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nginx
PORTVERSION= 1.24.0
-PORTREVISION?= 15
+PORTREVISION?= 16
PORTEPOCH= 3
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
diff --git a/www/nginx/Makefile.extmod b/www/nginx/Makefile.extmod
index f3f6d0526210..2f68a38b8462 100644
--- a/www/nginx/Makefile.extmod
+++ b/www/nginx/Makefile.extmod
@@ -11,9 +11,9 @@ OPTIONS_GROUP_THIRDPARTYGRP= AJP AWS_AUTH BROTLI CACHE_PURGE CLOJURE COOKIE_FLAG
HTTP_PUSH_STREAM HTTP_REDIS HTTP_SLICE_AHEAD HTTP_SUBS_FILTER HTTP_TARANTOOL \
HTTP_UPLOAD HTTP_UPLOAD_PROGRESS HTTP_UPSTREAM_CHECK HTTP_UPSTREAM_FAIR \
HTTP_UPSTREAM_STICKY HTTP_VIDEO_THUMBEXTRACTOR HTTP_ZIP ICONV LET LINK LUA MEMC \
- MODSECURITY3 NAXSI OPENTRACING PASSENGER POSTGRES RDS_CSV RDS_JSON \
- REDIS2 RTMP SET_MISC SFLOW SHIBBOLETH SLOWFS_CACHE SRCACHE STS \
- VOD VTS XSS WEBSOCKIFY
+ MODSECURITY3 NAXSI PASSENGER POSTGRES RDS_CSV RDS_JSON REDIS2\
+ RTMP SET_MISC SFLOW SHIBBOLETH SLOWFS_CACHE SRCACHE STS VOD VTS \
+ XSS WEBSOCKIFY
AJP_GH_TUPLE= msva:nginx_ajp_module:fcbb2cc:ajp
AJP_VARS= DSO_EXTMODS+=ajp
@@ -255,11 +255,6 @@ NJS_XML_IMPLIES= NJS
NJS_XML_LIB_DEPENDS= libxml2.so:textproc/libxml2 \
libxslt.so:textproc/libxslt
-OPENTRACING_GH_TUPLE= opentracing-contrib:nginx-opentracing:v0.24.0:opentracing
-OPENTRACING_LIB_DEPENDS= libopentracing.so:devel/libopentracing
-OPENTRACING_VARS= DSO_EXTMODS+=opentracing OPENTRACING_SUBDIR=/opentracing
-OPENTRACING_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-nginx-opentracing-opentracing-config
-
PASSENGER_NGINX_VER= 6.0.17
PASSENGER_CATEGORIES= ruby
PASSENGER_USES= ruby
diff --git a/www/nginx/Makefile.options.desc b/www/nginx/Makefile.options.desc
index dc7f5a7c47a1..598e1f75a83f 100644
--- a/www/nginx/Makefile.options.desc
+++ b/www/nginx/Makefile.options.desc
@@ -93,7 +93,6 @@ MODSECURITY3_DESC= 3rd party modsecurity3 module
NAXSI_DESC= 3rd party naxsi module
NJS_DESC= Enable javascript (NJS) module
NJS_XML_DESC= Enable XML functionality in NJS module
-OPENTRACING_DESC= 3rd party opentracing module
PASSENGER_DESC= 3rd party passenger module
POSTGRES_DESC= 3rd party postgres module
RDS_CSV_DESC= 3rd party rds_csv module
diff --git a/www/nginx/files/extra-patch-nginx-opentracing-opentracing-config b/www/nginx/files/extra-patch-nginx-opentracing-opentracing-config
deleted file mode 100644
index 1c40dd108b95..000000000000
--- a/www/nginx/files/extra-patch-nginx-opentracing-opentracing-config
+++ /dev/null
@@ -1,8 +0,0 @@
---- ../nginx-opentracing-0.24.0/opentracing/config.orig 2020-05-07 18:34:12.853828000 -0400
-+++ ../nginx-opentracing-0.24.0/opentracing/config 2020-05-07 18:34:26.521814000 -0400
-@@ -34,4 +34,4 @@
-
- . auto/module
-
--OT_NGX_SRCS="$ngx_module_srcs"
-+#OT_NGX_SRCS="$ngx_module_srcs"
diff --git a/www/nginx/pkg-plist b/www/nginx/pkg-plist
index 1b784d1d3c92..94e0cd5e7946 100644
--- a/www/nginx/pkg-plist
+++ b/www/nginx/pkg-plist
@@ -68,7 +68,6 @@
%%DSO%%%%MEMC%%libexec/nginx/ngx_http_memc_module.so
%%DSO%%%%MODSECURITY3%%libexec/nginx/ngx_http_modsecurity_module.so
%%DSO%%%%NAXSI%%libexec/nginx/ngx_http_naxsi_module.so
-%%DSO%%%%OPENTRACING%%libexec/nginx/ngx_http_opentracing_module.so
%%DSO%%%%PASSENGER%%libexec/nginx/ngx_http_passenger_module.so
%%DSO%%%%POSTGRES%%libexec/nginx/ngx_postgres_module.so
%%DSO%%%%RDS_CSV%%libexec/nginx/ngx_http_rds_csv_filter_module.so