aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2020-06-06 10:45:27 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2020-06-06 10:45:27 +0000
commit995f7b54d1fa58c4c1911b99b07cd5ac731a675d (patch)
treef116c603fe27dbcd0bd4674ea8940d7661d8e22e /www/nginx
parent52548ea55dc9a1d955e161144b15a377e3ac0deb (diff)
downloadports-995f7b54d1fa58c4c1911b99b07cd5ac731a675d.tar.gz
ports-995f7b54d1fa58c4c1911b99b07cd5ac731a675d.zip
Merge r533146 from www/nginx-devel:
Convert another 3 third-party modules to dynamic: o) ngx_http_subs_filter o) ngx_http_upstream_check o) ngx_http_response Sponsored by: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=538085
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/Makefile.extmod12
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-nginx_upstream_check_module-config32
-rw-r--r--www/nginx/files/extra-patch-ngx_http_response-config11
-rw-r--r--www/nginx/pkg-plist3
6 files changed, 57 insertions, 9 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 2f3ee779e4ad..a5afd5a31218 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.18.0
-PORTREVISION?= 11
+PORTREVISION?= 12
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
diff --git a/www/nginx/Makefile.extmod b/www/nginx/Makefile.extmod
index f6ee98f03398..8364120c4b46 100644
--- a/www/nginx/Makefile.extmod
+++ b/www/nginx/Makefile.extmod
@@ -157,12 +157,13 @@ HTTP_REDIS_VARS= DSO_EXTDIRS+=ngx_http_redis-0.3.9
HTTP_RESPONSE_MASTER_SITES= http://catap.ru/downloads/nginx/:response
HTTP_RESPONSE_DISTFILES= ngx_http_response-0.3.tar.gz:response
-HTTP_RESPONSE_CONFIGURE_ON= --add-module=${WRKDIR}/ngx_http_response-0.3
+HTTP_RESPONSE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_http_response-config
+HTTP_RESPONSE_VARS= DSO_EXTDIRS+=ngx_http_response-0.3
HTTP_SLICE_AHEAD_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src_http_modules_ngx__http__slice_read_ahead.c
-HTTP_SUBS_FILTER_GH_TUPLE= yaoweibin:ngx_http_substitutions_filter_module:v0.6.4:subs_filter
-HTTP_SUBS_FILTER_CONFIGURE_ON= --add-module=${WRKSRC_subs_filter}
+HTTP_SUBS_FILTER_GH_TUPLE= yaoweibin:ngx_http_substitutions_filter_module:b8a71ea:subs_filter
+HTTP_SUBS_FILTER_VARS= DSO_EXTMODS+=subs_filter
HTTP_TARANTOOL_LIB_DEPENDS= libmsgpuck.so:devel/msgpuck \
libyajl.so:devel/yajl
@@ -178,12 +179,13 @@ HTTP_UPLOAD_PROGRESS_GH_TUPLE= masterzen:nginx-upload-progress-module:afb2d31:up
HTTP_UPLOAD_PROGRESS_VARS= DSO_EXTMODS+=uploadprogress
HTTP_UPSTREAM_CHECK_GH_TUPLE= yaoweibin:nginx_upstream_check_module:9aecf15:upstreamcheck
-HTTP_UPSTREAM_CHECK_CONFIGURE_ON= --add-module=${WRKSRC_upstreamcheck}
HTTP_UPSTREAM_CHECK_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-http-modules-ngx_http_upstream_hash_module.c \
${PATCHDIR}/extra-patch-src-http-modules-ngx_http_upstream_ip_hash_module.c \
${PATCHDIR}/extra-patch-src-http-modules-ngx_http_upstream_least_conn_module.c \
${PATCHDIR}/extra-patch-src-http-ngx_http_upstream_round_robin.c \
- ${PATCHDIR}/extra-patch-src-http-ngx_http_upstream_round_robin.h
+ ${PATCHDIR}/extra-patch-src-http-ngx_http_upstream_round_robin.h \
+ ${PATCHDIR}/extra-patch-nginx_upstream_check_module-config
+HTTP_UPSTREAM_CHECK_VARS= DSO_EXTMODS+=upstreamcheck
HTTP_UPSTREAM_FAIR_GH_TUPLE= jaygooby:nginx-upstream-fair:10ecdcf:upstreamfair
HTTP_UPSTREAM_FAIR_VARS= DSO_EXTMODS+=upstreamfair
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 6619366f5662..14024bea3cfa 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1591369113
+TIMESTAMP = 1591435465
SHA256 (nginx-1.18.0.tar.gz) = 4c373e7ab5bf91d34a4f11a0c9496561061ba5eee6020db272a17a7228d35f99
SIZE (nginx-1.18.0.tar.gz) = 1039530
SHA256 (ngx_cache_purge-2.3.tar.gz) = 279e0d8a46d3b1521fd43b3f78bc1c08b263899142a7cc5058c1c0361a92c89c
@@ -81,8 +81,8 @@ SHA256 (slact-nchan-v1.1.14_GH0.tar.gz) = 70b38d9e54826b2a69a9a5f3de5fb0e25fb031
SIZE (slact-nchan-v1.1.14_GH0.tar.gz) = 630564
SHA256 (wandenberg-nginx-push-stream-module-0.5.4_GH0.tar.gz) = 5253bb8a804ea679e514137a234637298f044c3ef63c053670bf3802ff3535b1
SIZE (wandenberg-nginx-push-stream-module-0.5.4_GH0.tar.gz) = 183493
-SHA256 (yaoweibin-ngx_http_substitutions_filter_module-v0.6.4_GH0.tar.gz) = ed4ddbcf0c434f4a1e97b61251a63ace759792764bd5cb79ff20efe348db8db3
-SIZE (yaoweibin-ngx_http_substitutions_filter_module-v0.6.4_GH0.tar.gz) = 92230
+SHA256 (yaoweibin-ngx_http_substitutions_filter_module-b8a71ea_GH0.tar.gz) = 08f966328fc1b77e0dbbcacd9532c3905060c20c45b6461b6f2075cd844d0891
+SIZE (yaoweibin-ngx_http_substitutions_filter_module-b8a71ea_GH0.tar.gz) = 94039
SHA256 (tarantool-nginx_upstream_module-1278ee5_GH0.tar.gz) = 34d51afcd464582e6011a5d3abe6829c5690ddb9b50c993dfdafb4c725a4803a
SIZE (tarantool-nginx_upstream_module-1278ee5_GH0.tar.gz) = 48378
SHA256 (fdintino-nginx-upload-module-aa42509_GH0.tar.gz) = 2285245bdef11656e5bcc866e693e48f84b7443d36924f45a6fb8647cd35319a
diff --git a/www/nginx/files/extra-patch-nginx_upstream_check_module-config b/www/nginx/files/extra-patch-nginx_upstream_check_module-config
new file mode 100644
index 000000000000..17a3d5c104e8
--- /dev/null
+++ b/www/nginx/files/extra-patch-nginx_upstream_check_module-config
@@ -0,0 +1,32 @@
+--- ../nginx_upstream_check_module-9aecf15/config.orig 2020-04-27 09:51:23.976467000 -0400
++++ ../nginx_upstream_check_module-9aecf15/config 2020-04-27 09:54:11.429571000 -0400
+@@ -1,23 +1,7 @@
+-ngx_feature="ngx_http_upstream_check_module"
+-ngx_feature_name=
+-ngx_feature_run=no
+-ngx_feature_incs=
+-ngx_feature_path="$ngx_addon_dir"
+-ngx_feature_deps="$ngx_addon_dir/ngx_http_upstream_check_module.h"
+-ngx_check_src="$ngx_addon_dir/ngx_http_upstream_check_module.c"
+-ngx_feature_test="int a;"
+-. auto/feature
++ngx_addon_name=ngx_http_upstream_check_module
++ngx_module_name="$ngx_addon_name"
++ngx_module_type=HTTP
++ngx_module_deps="$ngx_addon_dir/ngx_http_upstream_check_module.h"
++ngx_module_srcs="$ngx_addon_dir/ngx_http_upstream_check_module.c"
+
+-if [ $ngx_found = yes ]; then
+- have=NGX_HTTP_UPSTREAM_CHECK . auto/have
+- CORE_INCS="$CORE_INCS $ngx_feature_path"
+- ngx_addon_name=ngx_http_upstream_check_module
+- HTTP_MODULES="$HTTP_MODULES ngx_http_upstream_check_module"
+- NGX_ADDON_DEPS="$NGX_ADDON_DEPS $ngx_feature_deps"
+- NGX_ADDON_SRCS="$NGX_ADDON_SRCS $ngx_check_src"
+-else
+- cat << END
+- $0: error: the ngx_http_upstream_check_module addon error.
+-END
+- exit 1
+-fi
++. auto/module
diff --git a/www/nginx/files/extra-patch-ngx_http_response-config b/www/nginx/files/extra-patch-ngx_http_response-config
new file mode 100644
index 000000000000..3b39255595cd
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_response-config
@@ -0,0 +1,11 @@
+--- ../ngx_http_response-0.3/config.orig 2020-04-27 11:41:14.626983000 -0400
++++ ../ngx_http_response-0.3/config 2020-04-27 11:41:50.008905000 -0400
+@@ -1,3 +1,6 @@
+ ngx_addon_name=ngx_http_response_module
+-HTTP_MODULES="$HTTP_MODULES ngx_http_response_module"
+-NGX_ADDON_SRCS="$NGX_ADDON_SRCS $ngx_addon_dir/ngx_http_response_module.c"
++ngx_module_name="$ngx_addon_name"
++ngx_module_type=HTTP
++ngx_module_srcs="$ngx_addon_dir/ngx_http_response_module.c"
++ngx_module_deps=""
++. auto/module
diff --git a/www/nginx/pkg-plist b/www/nginx/pkg-plist
index 08fc43b57720..5e1fe66f0884 100644
--- a/www/nginx/pkg-plist
+++ b/www/nginx/pkg-plist
@@ -48,9 +48,12 @@
%%DSO%%%%HTTP_PUSH%%libexec/nginx/ngx_nchan_module.so
%%DSO%%%%HTTP_PUSH_STREAM%%libexec/nginx/ngx_http_push_stream_module.so
%%DSO%%%%HTTP_REDIS%%libexec/nginx/ngx_http_redis_module.so
+%%DSO%%%%HTTP_RESPONSE%%libexec/nginx/ngx_http_response_module.so
+%%DSO%%%%HTTP_SUBS_FILTER%%libexec/nginx/ngx_http_subs_filter_module.so
%%DSO%%%%HTTP_TARANTOOL%%libexec/nginx/ngx_http_tnt_module.so
%%DSO%%%%HTTP_UPLOAD%%libexec/nginx/ngx_http_upload_module.so
%%DSO%%%%HTTP_UPLOAD_PROGRESS%%libexec/nginx/ngx_http_uploadprogress_module.so
+%%DSO%%%%HTTP_UPSTREAM_CHECK%%libexec/nginx/ngx_http_upstream_check_module.so
%%DSO%%%%HTTP_UPSTREAM_FAIR%%libexec/nginx/ngx_http_upstream_fair_module.so
%%DSO%%%%HTTP_UPSTREAM_STICKY%%libexec/nginx/ngx_http_sticky_module.so
%%DSO%%%%HTTP_VIDEO_THUMBEXTRACTOR%%libexec/nginx/ngx_http_video_thumbextractor_module.so