aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2020-12-29 22:33:41 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2020-12-29 22:33:41 +0000
commitce737071630314fc69899e32eb490c3e627286df (patch)
tree47eeae658f66a8da90e49588b32ba457be6b30c2 /www/nginx
parentc78beee722c91772ffd7309d95554ac2118834e2 (diff)
downloadports-ce737071630314fc69899e32eb490c3e627286df.tar.gz
ports-ce737071630314fc69899e32eb490c3e627286df.zip
merge r559454 from www/nginx-devel:
Fix PROPFIND fail with 500 on simlinks to non exist file/dir when nginx compiled with the third-party http_dav_ext module. PR: 220871 Sponsored by: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=559626
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/Makefile.extmod1
-rw-r--r--www/nginx/files/extra-patch-ngx_http_dav_ext_module.c15
3 files changed, 17 insertions, 1 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 5f2b0d861e67..a5f09392869f 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.18.0
-PORTREVISION?= 43
+PORTREVISION?= 44
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
diff --git a/www/nginx/Makefile.extmod b/www/nginx/Makefile.extmod
index 4d6624ad25af..0705155ff1bf 100644
--- a/www/nginx/Makefile.extmod
+++ b/www/nginx/Makefile.extmod
@@ -93,6 +93,7 @@ HTTP_DAV_EXT_IMPLIES= HTTP_DAV
HTTP_DAV_EXT_LIB_DEPENDS= libexpat.so:textproc/expat2
HTTP_DAV_EXT_GH_TUPLE= arut:nginx-dav-ext-module:v3.0.0:dav_ext
HTTP_DAV_EXT_VARS= DSO_EXTMODS+=dav_ext
+HTTP_DAV_EXT_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_http_dav_ext_module.c
HTTP_EVAL_GH_TUPLE= openresty:nginx-eval-module:582bd25:eval
HTTP_EVAL_VARS= DSO_EXTMODS+=eval
diff --git a/www/nginx/files/extra-patch-ngx_http_dav_ext_module.c b/www/nginx/files/extra-patch-ngx_http_dav_ext_module.c
new file mode 100644
index 000000000000..cf66be99de49
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_dav_ext_module.c
@@ -0,0 +1,15 @@
+--- ../nginx-dav-ext-module-3.0.0/ngx_http_dav_ext_module.c 2018-12-17 11:45:12.000000000 +0300
++++ ../nginx-dav-ext-module-3.0.0/ngx_http_dav_ext_module.c 2020-03-13 01:20:47.498199000 +0300
+@@ -896,10 +896,9 @@
+ ngx_cpystrn(last, name.data, name.len + 1);
+
+ if (ngx_de_info(filename, &dir) == NGX_FILE_ERROR) {
+- ngx_log_error(NGX_LOG_CRIT, r->connection->log, ngx_errno,
++ ngx_log_error(NGX_LOG_ERR, r->connection->log, ngx_errno,
+ ngx_de_info_n " \"%s\" failed", filename);
+- rc = NGX_HTTP_INTERNAL_SERVER_ERROR;
+- break;
++ continue;
+ }
+ }
+