aboutsummaryrefslogtreecommitdiff
path: root/www/node-devel/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-21 15:06:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-21 15:06:21 +0000
commit6f491a2301bae6fca739f4129686a5e1c3b31a59 (patch)
treeb5b3f40cc5fe20cf2606ed0943beba14ba24fcaf /www/node-devel/Makefile
parentb2cc493e1613996ab9c943f055827e0c0bf56905 (diff)
downloadports-6f491a2301bae6fca739f4129686a5e1c3b31a59.tar.gz
ports-6f491a2301bae6fca739f4129686a5e1c3b31a59.zip
Notes
Diffstat (limited to 'www/node-devel/Makefile')
-rw-r--r--www/node-devel/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/node-devel/Makefile b/www/node-devel/Makefile
index 86a24fdbfef9..28f546e17236 100644
--- a/www/node-devel/Makefile
+++ b/www/node-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= node
-PORTVERSION= 0.7.10
+PORTVERSION= 0.7.12
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
PKGNAMESUFFIX= -devel
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= linpct@gmail.com
COMMENT= V8 javascript for client and server
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
MAN1= node.1
@@ -30,14 +30,16 @@ ONLY_FOR_ARCHS= i386 amd64
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} --without-npm
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
+REINPLACE_ARGS= -i ''
post-patch:
@${RM} ${WRKSRC}/tools/wafadmin/Node.py.orig
+ @${REINPLACE_CMD} -e 's|share/man/man1/|man/man1|' ${WRKSRC}/tools/installer.js
post-install:
${MKDIR} ${PREFIX}/lib/node_modules/
${TOUCH} ${PREFIX}/lib/node_modules/.keepme
- ${INSTALL_MAN} ${WRKSRC}/doc/node.1 ${MANPREFIX}/man/man1/
+ ${CHMOD} ${MANMODE} ${PREFIX}/man/man1/node.1
@${ECHO_MSG}
@${ECHO_MSG} "Note: If you need npm (Node Package Manager), please install www/npm."
@${ECHO_MSG}