aboutsummaryrefslogtreecommitdiff
path: root/www/node
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-02 13:03:09 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-02 13:03:09 +0000
commit6571551cb264ab4aed87ce13023a394c214c2b65 (patch)
tree493de38dcd4b1f507c1dcbb04b281b7ccf0daa2f /www/node
parent6d74c09abaa5632adc5751c3c203568dcecef95b (diff)
downloadports-6571551cb264ab4aed87ce13023a394c214c2b65.tar.gz
ports-6571551cb264ab4aed87ce13023a394c214c2b65.zip
www/node: fix build on powerpc64le
Building with DTRACE causes crash. -mminimal-toc is valid only on powerpc64 elfv1.
Notes
Notes: svn path=/head/; revision=553903
Diffstat (limited to 'www/node')
-rw-r--r--www/node/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index ea56d9964b3d..a02bac5e02fa 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -31,6 +31,7 @@ OPTIONS_EXCLUDE_aarch64= DTRACE
OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_powerpc64= DTRACE
+OPTIONS_EXCLUDE_powerpc64le= DTRACE
BUNDLED_SSL_DESC= Use node.js's bundled OpenSSL implementation
BUNDLED_SSL_USES_OFF= ssl
@@ -78,7 +79,7 @@ LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
.include <bsd.port.options.mk>
-.if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
+.if (defined(PPC_ABI) && ${PPC_ABI} == ELFv2) || ${ARCH} == powerpc64le
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-common.gypi
.endif