aboutsummaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-11-04 15:59:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-11-04 15:59:03 +0000
commit6054a16ce9477e60f0695a8fade7864fd6a7a4aa (patch)
treea03299c8b1aa0046a4801eec13c99778ae6c1aea /www/npm
parentddde84aea4a301a8e97dbd274383439d1dd6b1f0 (diff)
downloadports-6054a16ce9477e60f0695a8fade7864fd6a7a4aa.tar.gz
ports-6054a16ce9477e60f0695a8fade7864fd6a7a4aa.zip
Add NODE12 option
Notes
Notes: svn path=/head/; revision=516664
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index fb950f0d2e03..1bba7a9bac66 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -20,13 +20,14 @@ NO_ARCH= yes
NO_BUILD= yes
REINPLACE_ARGS= -i ''
-CONFLICTS_INSTALL?= npm-node10 npm-node8
+CONFLICTS_INSTALL?= npm-node10 npm-node12 npm-node8
OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE NODE10 NODE8
+OPTIONS_SINGLE_BACKEND= NODE NODE10 NODE12 NODE8
OPTIONS_DEFAULT=NODE
-NODE_DESC= Use Node.js 11.x/12.x (www/node) as backend
+NODE_DESC= Use Node.js 13.x (www/node) as backend
NODE10_DESC= Use Node.js 10.x (www/node10) as backend
+NODE12_DESC= Use Node.js 12.x (www/node12) as backend
NODE8_DESC= Use Node.js 8.x (www/node8) as backend
CPE_VENDOR= npmjs
@@ -37,6 +38,7 @@ SHEBANG_FILES= lib/node_modules/npm/node_modules/node-gyp/gyp/samples/samples
NODE_RUN_DEPENDS= node>=0.8.0:www/node
NODE10_RUN_DEPENDS= node10>=0.8.0:www/node10
+NODE12_RUN_DEPENDS= node12>=0.8.0:www/node12
NODE8_RUN_DEPENDS= node8>=0.8.0:www/node8
.include <bsd.port.pre.mk>