aboutsummaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-11-20 04:30:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-11-20 04:30:31 +0000
commit908a9b155a10c875d999f951f2c510ae5c22c847 (patch)
tree69026f3eb88b96ce0152f073cd279ced1bc6eb92 /www/npm
parent84cd9221095be6a33cc2f623a931c630b339e8a1 (diff)
downloadports-908a9b155a10c875d999f951f2c510ae5c22c847.tar.gz
ports-908a9b155a10c875d999f951f2c510ae5c22c847.zip
Add Node.js 9.x support manually
- Bump PORTREVISION for package change
Notes
Notes: svn path=/head/; revision=454516
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile2
-rw-r--r--www/npm/files/patch-node912
2 files changed, 13 insertions, 1 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index e85943d27604..16dcf5184de4 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= npm
PORTVERSION= 5.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
diff --git a/www/npm/files/patch-node9 b/www/npm/files/patch-node9
new file mode 100644
index 000000000000..9f9d5acb8056
--- /dev/null
+++ b/www/npm/files/patch-node9
@@ -0,0 +1,12 @@
+--- lib/node_modules/npm/lib/utils/unsupported.js.orig 2017-09-15 00:42:12 UTC
++++ lib/node_modules/npm/lib/utils/unsupported.js
+@@ -4,7 +4,8 @@ var supportedNode = [
+ {ver: '4', min: '4.7.0'},
+ {ver: '6', min: '6.0.0'},
+ {ver: '7', min: '7.0.0'},
+- {ver: '8', min: '8.0.0'}
++ {ver: '8', min: '8.0.0'},
++ {ver: '9', min: '9.0.0'}
+ ]
+ var knownBroken = '<4.7.0'
+