aboutsummaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-20 13:46:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-20 13:46:55 +0000
commite5d6837b95181250109a5ea23efb3e30bbcc5b9a (patch)
treed6c5e344f0e11d9c2064065a83864f0fed8434c7 /www/npm
parent1ec72a9ad9d9a302c8a89f3586a75fa270560b7c (diff)
downloadports-e5d6837b95181250109a5ea23efb3e30bbcc5b9a.tar.gz
ports-e5d6837b95181250109a5ea23efb3e30bbcc5b9a.zip
Notes
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile6
-rw-r--r--www/npm/distinfo4
-rw-r--r--www/npm/pkg-plist13
3 files changed, 18 insertions, 5 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 18be47847c6d..968b5cd2dd43 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= npm
-PORTVERSION= 1.3.7
+PORTVERSION= 1.3.8
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -28,7 +28,7 @@ MAN1= npm.1 npm-README.1 npm-adduser.1 npm-bin.1 npm-bugs.1 \
npm-run-script.1 npm-search.1 npm-shrinkwrap.1 npm-star.1 \
npm-stars.1 npm-start.1 npm-stop.1 npm-submodule.1 npm-tag.1 \
npm-test.1 npm-uninstall.1 npm-unpublish.1 npm-update.1 \
- npm-version.1 npm-view.1 npm-whoami.1
+ npm-version.1 npm-view.1 npm-whoami.1 repo.1
MAN3= npm.3 npm-bin.3 npm-bugs.3 npm-commands.3 npm-config.3 \
npm-deprecate.3 npm-docs.3 npm-edit.3 npm-explore.3 \
npm-help-search.3 npm-init.3 npm-install.3 npm-link.3 \
@@ -37,7 +37,7 @@ MAN3= npm.3 npm-bin.3 npm-bugs.3 npm-commands.3 npm-config.3 \
npm-restart.3 npm-root.3 npm-run-script.3 npm-search.3 \
npm-shrinkwrap.3 npm-start.3 npm-stop.3 npm-submodule.3 \
npm-tag.3 npm-test.3 npm-uninstall.3 npm-unpublish.3 \
- npm-update.3 npm-version.3 npm-view.3 npm-whoami.3
+ npm-update.3 npm-version.3 npm-view.3 npm-whoami.3 repo.3
MAN5= npm-folders.5 npm-global.5 npm-json.5 npmrc.5 package.json.5
MAN7= npm-coding-style.7 npm-config.7 npm-developers.7 \
npm-disputes.7 npm-faq.7 npm-index.7 npm-registry.7 \
diff --git a/www/npm/distinfo b/www/npm/distinfo
index e1edee99800c..4c56d64da5a3 100644
--- a/www/npm/distinfo
+++ b/www/npm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (npm-1.3.7.tar.xz) = f4095eb2a5b3a3317bf0d08e925ff6030772a7b470a2127c2aeff918ace694e4
-SIZE (npm-1.3.7.tar.xz) = 1783676
+SHA256 (npm-1.3.8.tar.xz) = de715de676a09f6fc4b0c53f41aacd136935a9b995fdc0974ac5e1d92b28bc14
+SIZE (npm-1.3.8.tar.xz) = 1785624
diff --git a/www/npm/pkg-plist b/www/npm/pkg-plist
index ef7c5a48749c..0cd89c452dc2 100644
--- a/www/npm/pkg-plist
+++ b/www/npm/pkg-plist
@@ -51,6 +51,7 @@ lib/node_modules/npm/doc/api/npm-version.md
lib/node_modules/npm/doc/api/npm-view.md
lib/node_modules/npm/doc/api/npm-whoami.md
lib/node_modules/npm/doc/api/npm.md
+lib/node_modules/npm/doc/api/repo.md
lib/node_modules/npm/doc/cli/npm-adduser.md
lib/node_modules/npm/doc/cli/npm-bin.md
lib/node_modules/npm/doc/cli/npm-bugs.md
@@ -97,6 +98,7 @@ lib/node_modules/npm/doc/cli/npm-version.md
lib/node_modules/npm/doc/cli/npm-view.md
lib/node_modules/npm/doc/cli/npm-whoami.md
lib/node_modules/npm/doc/cli/npm.md
+lib/node_modules/npm/doc/cli/repo.md
lib/node_modules/npm/doc/files/npm-folders.md
lib/node_modules/npm/doc/files/npmrc.md
lib/node_modules/npm/doc/files/package.json.md
@@ -149,6 +151,7 @@ lib/node_modules/npm/html/doc/api/npm-version.html
lib/node_modules/npm/html/doc/api/npm-view.html
lib/node_modules/npm/html/doc/api/npm-whoami.html
lib/node_modules/npm/html/doc/api/npm.html
+lib/node_modules/npm/html/doc/api/repo.html
lib/node_modules/npm/html/doc/cli/npm-adduser.html
lib/node_modules/npm/html/doc/cli/npm-bin.html
lib/node_modules/npm/html/doc/cli/npm-bugs.html
@@ -195,6 +198,7 @@ lib/node_modules/npm/html/doc/cli/npm-version.html
lib/node_modules/npm/html/doc/cli/npm-view.html
lib/node_modules/npm/html/doc/cli/npm-whoami.html
lib/node_modules/npm/html/doc/cli/npm.html
+lib/node_modules/npm/html/doc/cli/repo.html
lib/node_modules/npm/html/doc/files/npm-folders.html
lib/node_modules/npm/html/doc/files/npm-global.html
lib/node_modules/npm/html/doc/files/npm-json.html
@@ -247,6 +251,7 @@ lib/node_modules/npm/lib/prefix.js
lib/node_modules/npm/lib/prune.js
lib/node_modules/npm/lib/publish.js
lib/node_modules/npm/lib/rebuild.js
+lib/node_modules/npm/lib/repo.js
lib/node_modules/npm/lib/restart.js
lib/node_modules/npm/lib/root.js
lib/node_modules/npm/lib/run-script.js
@@ -407,6 +412,13 @@ lib/node_modules/npm/node_modules/fstream/lib/reader.js
lib/node_modules/npm/node_modules/fstream/lib/socket-reader.js
lib/node_modules/npm/node_modules/fstream/lib/writer.js
lib/node_modules/npm/node_modules/fstream/package.json
+lib/node_modules/npm/node_modules/github-url-from-git/.npmignore
+lib/node_modules/npm/node_modules/github-url-from-git/History.md
+lib/node_modules/npm/node_modules/github-url-from-git/Makefile
+lib/node_modules/npm/node_modules/github-url-from-git/Readme.md
+lib/node_modules/npm/node_modules/github-url-from-git/index.js
+lib/node_modules/npm/node_modules/github-url-from-git/package.json
+lib/node_modules/npm/node_modules/github-url-from-git/test.js
lib/node_modules/npm/node_modules/glob/.npmignore
lib/node_modules/npm/node_modules/glob/.travis.yml
lib/node_modules/npm/node_modules/glob/LICENSE
@@ -1526,6 +1538,7 @@ lib/node_modules/npm/test/update-test.sh
@dirrm lib/node_modules/npm/node_modules/glob/test
@dirrm lib/node_modules/npm/node_modules/glob/examples
@dirrm lib/node_modules/npm/node_modules/glob
+@dirrm lib/node_modules/npm/node_modules/github-url-from-git
@dirrm lib/node_modules/npm/node_modules/fstream/lib
@dirrm lib/node_modules/npm/node_modules/fstream/examples
@dirrm lib/node_modules/npm/node_modules/fstream-npm/node_modules/fstream-ignore/test