aboutsummaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-11-18 14:17:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-11-18 14:17:10 +0000
commitf3827575907b2b09d82f6e80a6bccf780b28fd2c (patch)
tree5107995a019b0e20708c9823c9dc14af78c387fa /www/npm
parent6752e74df8154d527cf467a5caf6e80f8ac1a3b9 (diff)
downloadports-f3827575907b2b09d82f6e80a6bccf780b28fd2c.tar.gz
ports-f3827575907b2b09d82f6e80a6bccf780b28fd2c.zip
Update options for Node.js 8.x and 9.x
- Bump PORTREVISION for dependency change
Notes
Notes: svn path=/head/; revision=454435
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 90adc005e2bb..e85943d27604 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= npm
PORTVERSION= 5.4.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -16,11 +17,12 @@ RUN_DEPENDS= gmake:devel/gmake
CONFLICTS_INSTALL= npm2 npm3 npm4
OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE4 NODE6 NODE8
-OPTIONS_DEFAULT=NODE8
+OPTIONS_SINGLE_BACKEND= NODE NODE4 NODE6 NODE8
+OPTIONS_DEFAULT=NODE
+NODE_DESC= Use Node.js 9.x (www/node) as backend
NODE4_DESC= Use Node.js 4.x (www/node4) as backend
NODE6_DESC= Use Node.js 6.x (www/node6) as backend
-NODE8_DESC= Use Node.js 8.x (www/node) as backend
+NODE8_DESC= Use Node.js 8.x (www/node8) as backend
NO_ARCH= yes
NO_BUILD= yes
@@ -33,9 +35,10 @@ CPE_PRODUCT= node_packaged_modules
SHEBANG_GLOB= *.py
SHEBANG_FILES= lib/node_modules/npm/node_modules/node-gyp/gyp/samples/samples
+NODE_RUN_DEPENDS= node>=0.8.0:www/node
NODE4_RUN_DEPENDS= node4>=0.8.0:www/node4
NODE6_RUN_DEPENDS= node6>=0.8.0:www/node6
-NODE8_RUN_DEPENDS= node>=0.8.0:www/node
+NODE8_RUN_DEPENDS= node8>=0.8.0:www/node8
.include <bsd.port.pre.mk>