aboutsummaryrefslogtreecommitdiff
path: root/www/nscache
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-19 19:54:45 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-19 19:54:45 +0000
commitc9a2e9a5d169d94b29b638e893ba310e400422a3 (patch)
tree9d0503d6cfd67c7a5f27473f944864fdd8656ed7 /www/nscache
parentf50de67ab5b5ff64c28ebedd588e1ac00b5a4dd6 (diff)
downloadports-c9a2e9a5d169d94b29b638e893ba310e400422a3.tar.gz
ports-c9a2e9a5d169d94b29b638e893ba310e400422a3.zip
Notes
Diffstat (limited to 'www/nscache')
-rw-r--r--www/nscache/Makefile34
-rw-r--r--www/nscache/files/patch-aa23
-rw-r--r--www/nscache/files/patch-ab25
-rw-r--r--www/nscache/pkg-plist4
4 files changed, 20 insertions, 66 deletions
diff --git a/www/nscache/Makefile b/www/nscache/Makefile
index 172899ade472..2bee028c777e 100644
--- a/www/nscache/Makefile
+++ b/www/nscache/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= nscache
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.6
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.idata.sk/~ondrej/sw/
@@ -18,20 +18,22 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Netscape cache browser
USE_X_PREFIX= yes
-WANT_GNOME= yes
-USE_AUTOMAKE_VER= 14
-AUTOMAKE_ARGS= --include-deps
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
+USE_GNOME= gnomehier gtk12
+USE_GETOPT_LONG= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG} --disable-gnome
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
-.include <bsd.port.pre.mk>
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
-.if defined(HAVE_GNOME)
-USE_GNOME+= gtk12
-PKGNAMESUFFIX= -gtk
-.else
-CONFIGURE_ARGS+= --disable-gnome
-.endif
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/nscache.desktop \
+ ${PREFIX}/share/gnome/apps/Internet
+ ${INSTALL_DATA} ${WRKSRC}/nscache.xpm \
+ ${PREFIX}/share/gnome/pixmaps
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/nscache/files/patch-aa b/www/nscache/files/patch-aa
deleted file mode 100644
index 9e36f9379181..000000000000
--- a/www/nscache/files/patch-aa
+++ /dev/null
@@ -1,23 +0,0 @@
---- configure.in.orig Sun Jan 14 20:49:31 2001
-+++ configure.in Tue Jan 16 03:06:10 2001
-@@ -195,13 +195,15 @@
- fi
-
- if eval "test x$WITH_GNOME = xyes"; then
-- AC_CHECK_PROG(GNOME_CONFIG, gnome-config, "yes", "no")
-- if eval "test x$GNOME_CONFIG = xyes"; then
-- GNOME_PREFIX=`gnome-config --prefix`
-+ AC_PATH_PROG(GNOME_CONFIG, gnome-config, "no")
-+ if eval "test x$GNOME_CONFIG = no"; then
-+ GNOME_PREFIX=
-+ else
-+ GNOME_PREFIX=`$GNOME_CONFIG --prefix`
- AC_WARN("Will install Gnome things to $GNOME_PREFIX")
- if eval "test x$WITH_GNOME = xyes"; then
-- GNOME_LIBS=`gnome-config --libs gnomeui`
-- GNOME_CFLAGS=`gnome-config --cflags gnomeui`
-+ GNOME_LIBS=`$GNOME_CONFIG --libs gnomeui`
-+ GNOME_CFLAGS=`$GNOME_CONFIG --cflags gnomeui`
- GNOME_CFLAGS="$GNOME_CFLAGS -DHAVE_GNOME"
- fi
- fi
diff --git a/www/nscache/files/patch-ab b/www/nscache/files/patch-ab
deleted file mode 100644
index e51a3ea74ce4..000000000000
--- a/www/nscache/files/patch-ab
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.am.orig Thu Oct 5 07:38:32 2000
-+++ Makefile.am Tue Jan 16 03:06:23 2001
-@@ -6,16 +6,16 @@
-
- install-data-local:
- if test -n "$(GNOME_PREFIX)"; then \
-- $(mkinstalldirs) $(DESTDIR)$(GNOME_PREFIX)/share/gnome/apps/Internet; \
-- $(INSTALL_DATA) $(srcdir)/nscache.desktop $(DESTDIR)$(GNOME_PREFIX)/share/gnome/apps/Internet; \
-- $(mkinstalldirs) $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps; \
-- $(INSTALL_DATA) $(srcdir)/nscache.xpm $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps; \
-+ $(mkinstalldirs) $(DESTDIR)$(datadir)/apps/Internet; \
-+ $(INSTALL_DATA) $(srcdir)/nscache.desktop $(DESTDIR)$(datadir)/apps/Internet; \
-+ $(mkinstalldirs) $(DESTDIR)$(datadir)/pixmaps; \
-+ $(INSTALL_DATA) $(srcdir)/nscache.xpm $(DESTDIR)$(datadir)/pixmaps; \
- fi
-
- uninstall-local:
- if test -n "$(GNOME_PREFIX)"; then \
-- rm -f $(DESTDIR)$(GNOME_PREFIX)/share/gnome/apps/Internet/nscache.desktop; \
-- rm -f $(DESTDIR)$(GNOME_PREFIX)/share/pixmaps/nscache.xpm; \
-+ rm -f $(DESTDIR)$(datadir)/apps/Internet/nscache.desktop; \
-+ rm -f $(DESTDIR)$(datadir)/pixmaps/nscache.xpm; \
- fi
-
-
diff --git a/www/nscache/pkg-plist b/www/nscache/pkg-plist
index 46cb0bed59c3..c67f02bef6d8 100644
--- a/www/nscache/pkg-plist
+++ b/www/nscache/pkg-plist
@@ -7,5 +7,5 @@ share/locale/ja/LC_MESSAGES/nscache.mo
share/locale/pt_BR/LC_MESSAGES/nscache.mo
share/locale/sk/LC_MESSAGES/nscache.mo
share/locale/tr/LC_MESSAGES/nscache.mo
-%%GNOME:%%share/gnome/apps/Internet/nscache.desktop
-%%GNOME:%%share/gnome/pixmaps/nscache.xpm
+share/gnome/apps/Internet/nscache.desktop
+share/gnome/pixmaps/nscache.xpm