aboutsummaryrefslogtreecommitdiff
path: root/www/nvu
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-01-14 02:31:48 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-01-14 02:31:48 +0000
commit67afebfdbe38dd01ecd0c1ef177608eb097752d9 (patch)
tree290061c56dba4db954ad07969d8962781078abb1 /www/nvu
parent158fb7b13ad9a93bb1d88896b7e83e902f38bd50 (diff)
downloadports-67afebfdbe38dd01ecd0c1ef177608eb097752d9.tar.gz
ports-67afebfdbe38dd01ecd0c1ef177608eb097752d9.zip
Notes
Diffstat (limited to 'www/nvu')
-rw-r--r--www/nvu/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in44
-rw-r--r--www/nvu/files/patch-xpcom::reflect::xptcall::src::md::unix::Makefile.in56
2 files changed, 36 insertions, 64 deletions
diff --git a/www/nvu/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in b/www/nvu/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
index c3eeaa2c5d70..cf733d1b744e 100644
--- a/www/nvu/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
+++ b/www/nvu/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
@@ -1,16 +1,44 @@
---- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig Wed Jan 12 15:11:40 2005
-+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in Wed Jan 12 15:11:40 2005
-@@ -52,6 +52,9 @@
- ifeq (amd64,$(OS_TEST))
- CPPSRCS := xptcinvoke_x86_64_linux.cpp xptcstubs_x86_64_linux.cpp
+$FreeBSD: /tmp/pcvs/ports/www/nvu/files/Attic/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in,v 1.3 2005-01-14 02:31:48 ahze Exp $
+
+--- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig Thu Aug 14 21:00:23 2003
++++ xpcom/reflect/xptcall/src/md/unix/Makefile.in Sun Feb 1 15:06:40 2004
+@@ -49,6 +49,9 @@
+ ifeq (86,$(findstring 86,$(OS_TEST)))
+ CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
endif
+ifeq (amd64,$(OS_TEST))
-+CPPSRCS := xptcinvoke_amd64_freebsd.cpp xptcstubs_amd64_freebsd.cpp
++CPPSRCS := xptcinvoke_x86_64_linux.cpp xptcstubs_x86_64_linux.cpp
+endif
endif
#
# New code for Linux, et. al., with gcc
-@@ -313,6 +316,15 @@
+@@ -60,7 +63,7 @@
+ endif
+ endif
+ # IA64 Linux
+-ifneq (,$(filter Linux,$(OS_ARCH)))
++ifneq (,$(filter Linux FreeBSD,$(OS_ARCH)))
+ ifneq (,$(findstring ia64,$(OS_TEST)))
+ CPPSRCS := xptcinvoke_ipf64.cpp xptcstubs_ipf64.cpp
+ ASFILES := xptcstubs_asm_ipf64.s xptcinvoke_asm_ipf64.s
+@@ -106,9 +109,15 @@
+ ASFILES := xptcinvoke_asm_osf1_alpha.s xptcstubs_asm_osf1_alpha.s
+ endif
+ #
++# FreeBSD/Alpha
++#
++ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDalpha)
++CPPSRCS := xptcinvoke_freebsd_alpha.cpp xptcstubs_freebsd_alpha.cpp
++endif
++#
+ # Linux/Alpha
+ #
+-ifneq (,$(filter Linuxalpha FreeBSDalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
++ifneq (,$(filter Linuxalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
+ CPPSRCS := xptcinvoke_linux_alpha.cpp xptcstubs_linux_alpha.cpp
+ endif
+ #
+@@ -294,6 +303,15 @@
ifeq ($(OS_ARCH)$(OS_TEST),NetBSDsparc)
CPPSRCS := xptcinvoke_sparc_netbsd.cpp xptcstubs_sparc_netbsd.cpp
ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
@@ -25,4 +53,4 @@
+endif
endif
#
- # FreeBSD/SPARC64
+ # Solaris/SPARC
diff --git a/www/nvu/files/patch-xpcom::reflect::xptcall::src::md::unix::Makefile.in b/www/nvu/files/patch-xpcom::reflect::xptcall::src::md::unix::Makefile.in
deleted file mode 100644
index dbdc47b6f8e4..000000000000
--- a/www/nvu/files/patch-xpcom::reflect::xptcall::src::md::unix::Makefile.in
+++ /dev/null
@@ -1,56 +0,0 @@
---- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig Thu Aug 14 21:00:23 2003
-+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in Sun Feb 1 14:31:25 2004
-@@ -49,6 +49,9 @@
- ifeq (86,$(findstring 86,$(OS_TEST)))
- CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
- endif
-+ifeq (amd64,$(OS_TEST))
-+CPPSRCS := xptcinvoke_amd64_freebsd.cpp xptcstubs_amd64_freebsd.cpp
-+endif
- endif
- #
- # New code for Linux, et. al., with gcc
-@@ -59,8 +62,8 @@
- CPPSRCS := xptcinvoke_gcc_x86_unix.cpp xptcstubs_gcc_x86_unix.cpp
- endif
- endif
--# IA64 Linux
--ifneq (,$(filter Linux,$(OS_ARCH)))
-+# IA64 Linux & FreeBSD
-+ifneq (,$(filter Linux FreeBSD,$(OS_ARCH)))
- ifneq (,$(findstring ia64,$(OS_TEST)))
- CPPSRCS := xptcinvoke_ipf64.cpp xptcstubs_ipf64.cpp
- ASFILES := xptcstubs_asm_ipf64.s xptcinvoke_asm_ipf64.s
-@@ -106,9 +109,15 @@
- ASFILES := xptcinvoke_asm_osf1_alpha.s xptcstubs_asm_osf1_alpha.s
- endif
- #
-+# FreeBSD/Alpha
-+#
-+ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDalpha)
-+CPPSRCS := xptcinvoke_freebsd_alpha.cpp xptcstubs_freebsd_alpha.cpp
-+endif
-+#
- # Linux/Alpha
- #
--ifneq (,$(filter Linuxalpha FreeBSDalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
-+ifneq (,$(filter Linuxalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
- CPPSRCS := xptcinvoke_linux_alpha.cpp xptcstubs_linux_alpha.cpp
- endif
- #
-@@ -294,6 +303,15 @@
- ifeq ($(OS_ARCH)$(OS_TEST),NetBSDsparc)
- CPPSRCS := xptcinvoke_sparc_netbsd.cpp xptcstubs_sparc_netbsd.cpp
- ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
-+endif
-+#
-+# FreeBSD/SPARC64
-+#
-+ifeq ($(OS_ARCH),FreeBSD)
-+ifneq (,$(findstring sparc,$(OS_TEST)))
-+CPPSRCS := xptcinvoke_sparc64_freebsd.cpp xptcstubs_sparc64_freebsd.cpp
-+ASFILES := xptcinvoke_asm_sparc64_freebsd.s xptcstubs_asm_sparcv9_solaris.s
-+endif
- endif
- #
- # Solaris/SPARC