aboutsummaryrefslogtreecommitdiff
path: root/www/osticket/Makefile
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2020-12-18 19:49:54 +0000
committerJuraj Lutter <otis@FreeBSD.org>2020-12-18 19:49:54 +0000
commit96ec9546b1d3608482dc93ae988a3deeb36fd90a (patch)
tree0a26fe83b6e0c898afab82ecfd5bab5b6ef9220f /www/osticket/Makefile
parent1ba30adf439df328d27fd0dd28826692944456fc (diff)
downloadports-96ec9546b1d3608482dc93ae988a3deeb36fd90a.tar.gz
ports-96ec9546b1d3608482dc93ae988a3deeb36fd90a.zip
Add new port www/osticket:
osTicket is a widely-used open source support ticket system. https://github.com/osTicket/osTicket Reviewed by: osa (mentor) Approved by: osa (mentor) Differential Revision: https://reviews.freebsd.org/D27640
Notes
Notes: svn path=/head/; revision=558404
Diffstat (limited to 'www/osticket/Makefile')
-rw-r--r--www/osticket/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/www/osticket/Makefile b/www/osticket/Makefile
new file mode 100644
index 000000000000..0572e4305be6
--- /dev/null
+++ b/www/osticket/Makefile
@@ -0,0 +1,50 @@
+# Created by: Juraj Lutter <otis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= osticket
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.15.1
+CATEGORIES= www
+MASTER_SITES= https://github.com/osTicket/osTicket/releases/download/v${DISTVERSION}/
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+DISTNAME= osTicket-v${DISTVERSION}
+
+MAINTAINER= otis@FreeBSD.org
+COMMENT= Widely-used open source support ticket system
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu@${PHP_FLAVOR}
+
+USES= php:web zip
+USE_PHP= gd gettext imap json mbstring mysqli xml
+NO_ARCH= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+SUB_LIST= DOCSDIR=${DOCSDIR} \
+ WWWGRP=${WWWGRP} \
+ WWWOWN=${WWWOWN}
+
+WRKSRC= ${WRKDIR}/upload
+
+PLIST_SUB= WWWGRP=${WWWGRP} \
+ WWWOWN=${WWWOWN}
+
+OPTIONS_DEFINE= DOCS
+
+_OSTDOCS= ISSUE_TEMPLATE.md LICENSE.txt README.md SECURITY.md \
+ UPGRADING.txt WHATSNEW.md
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/
+ ${MV} ${STAGEDIR}${WWWDIR}/include/ost-sampleconfig.php \
+ ${STAGEDIR}${WWWDIR}/include/ost-config.php.sample
+
+post-install:
+ ${RM} ${_OSTDOCS:S,^,${STAGEDIR}${WWWDIR}/,}
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${_OSTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>