aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-AuthenCache/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-10-23 08:13:38 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-10-23 08:13:38 +0000
commitf0e8694085c8947da318fef8ca0aed9d4fbb24b7 (patch)
treebef3e8bf4a6e6803e2ea97a9cebc8d9dc9b113fc /www/p5-Apache-AuthenCache/Makefile
parent60cbd05b046764d2e4a2062522dc7c9a68d634d3 (diff)
downloadports-f0e8694085c8947da318fef8ca0aed9d4fbb24b7.tar.gz
ports-f0e8694085c8947da318fef8ca0aed9d4fbb24b7.zip
Notes
Diffstat (limited to 'www/p5-Apache-AuthenCache/Makefile')
-rw-r--r--www/p5-Apache-AuthenCache/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/www/p5-Apache-AuthenCache/Makefile b/www/p5-Apache-AuthenCache/Makefile
index 95d08af0fc05..7114a813d21f 100644
--- a/www/p5-Apache-AuthenCache/Makefile
+++ b/www/p5-Apache-AuthenCache/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Apache-AuthenCache
-PORTVERSION= 0.05
+PORTVERSION= 1.00
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
@@ -15,13 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module that implements authentication caching
-BUILD_DEPENDS= ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
- ${SITE_PERL}/IPC/Cache.pm:${PORTSDIR}/devel/p5-IPC-Cache \
- ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS= ${SITE_PERL}/Time/Object.pm:${PORTSDIR}/devel/p5-Time-Object \
+ ${SITE_PERL}/IPC/Cache.pm:${PORTSDIR}/devel/p5-IPC-Cache
RUN_DEPENDS= ${BUILD_DEPENDS}
+.if defined(WITH_APACHE2)
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
+.endif
+
PERL_CONFIGURE= yes
MAN3= Apache::AuthenCache.3
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -a -exec ${RM} -f {} \;
+
.include <bsd.port.mk>