aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Session-ExpireSessions
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2009-03-15 19:11:43 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2009-03-15 19:11:43 +0000
commit405616748a9f13f0f0e79bbc339075bb9cb91833 (patch)
tree775b5691a94b60f2a93dc48986c95c333a5217ba /www/p5-CGI-Session-ExpireSessions
parentd8e2ac325cb556971ee9a651a8bd2781107e8246 (diff)
downloadports-405616748a9f13f0f0e79bbc339075bb9cb91833.tar.gz
ports-405616748a9f13f0f0e79bbc339075bb9cb91833.zip
Notes
Diffstat (limited to 'www/p5-CGI-Session-ExpireSessions')
-rw-r--r--www/p5-CGI-Session-ExpireSessions/Makefile27
-rw-r--r--www/p5-CGI-Session-ExpireSessions/distinfo3
-rw-r--r--www/p5-CGI-Session-ExpireSessions/pkg-descr11
-rw-r--r--www/p5-CGI-Session-ExpireSessions/pkg-plist9
4 files changed, 50 insertions, 0 deletions
diff --git a/www/p5-CGI-Session-ExpireSessions/Makefile b/www/p5-CGI-Session-ExpireSessions/Makefile
new file mode 100644
index 000000000000..67758ee78c3d
--- /dev/null
+++ b/www/p5-CGI-Session-ExpireSessions/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-CGI-Session-ExpireSessions
+# Date created: Wed, 11 March 2009 17:21:32 GMT
+# Whom: Gerard Seibert <gerard@seibercom.net>
+#
+# $FreeBSD$
+
+PORTNAME= CGI-Session-ExpireSessions
+PORTVERSION= 1.09
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gerard@seibercom.net
+COMMENT= Perl module to delete expired CGI::Session-type sessions
+
+BUILD_DEPENDS= p5-Test-Pod>=1.26:${PORTSDIR}/devel/p5-Test-Pod
+RUN_DEPENDS= p5-CGI-Session>=4.40:${PORTSDIR}/www/p5-CGI-Session \
+ p5-PathTools>=3.2900:${PORTSDIR}/devel/p5-PathTools
+
+MAN3= CGI::Session::ExpireSessions.3
+MANCOMPRESSED= no
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Session-ExpireSessions/distinfo b/www/p5-CGI-Session-ExpireSessions/distinfo
new file mode 100644
index 000000000000..dbbf8f36939e
--- /dev/null
+++ b/www/p5-CGI-Session-ExpireSessions/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Session-ExpireSessions-1.09.tgz) = e9dfc509f6aa228650c3a55d4dc7bc5c
+SHA256 (CGI-Session-ExpireSessions-1.09.tgz) = c022c84fc2e436ba62efc1ede80ba24d53399672a6abcfe31ddebecef141cf83
+SIZE (CGI-Session-ExpireSessions-1.09.tgz) = 12356
diff --git a/www/p5-CGI-Session-ExpireSessions/pkg-descr b/www/p5-CGI-Session-ExpireSessions/pkg-descr
new file mode 100644
index 000000000000..a91952a5a7a5
--- /dev/null
+++ b/www/p5-CGI-Session-ExpireSessions/pkg-descr
@@ -0,0 +1,11 @@
+CGI::Session::ExpireSessions is a pure Perl module.
+
+It deletes CGI::Session-type sessions which have passed their use-by date.
+
+It works with CGI::Session-type sessions in a database or in disk files,
+but does not appear to work with CGI::Session::PureSQL-type sessions.
+
+The recommended way to use this module is via method expire_sessions(),
+which requires CGI::Session V 4 or later.
+
+WWW: http://search.cpan.org/~rsavage/CGI-Session-ExpireSessions-1.09/
diff --git a/www/p5-CGI-Session-ExpireSessions/pkg-plist b/www/p5-CGI-Session-ExpireSessions/pkg-plist
new file mode 100644
index 000000000000..5178aa8cf4d6
--- /dev/null
+++ b/www/p5-CGI-Session-ExpireSessions/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Session/ExpireSessions/.packlist
+%%SITE_PERL%%/CGI/Session/ExpireSessions.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Session
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Session/ExpireSessions
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/CGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/CGI/Session