aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-ConfigLoader
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2006-07-11 17:34:14 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2006-07-11 17:34:14 +0000
commit9887dd967e6f952ec2d284ba14fbae2a7db0ab8a (patch)
tree860dadeb4a791d0ec6a4959ae388ab746561b916 /www/p5-Catalyst-Plugin-ConfigLoader
parentd213f1c3bb68b3f3a14e6e063b669bff3b610e57 (diff)
downloadports-9887dd967e6f952ec2d284ba14fbae2a7db0ab8a.tar.gz
ports-9887dd967e6f952ec2d284ba14fbae2a7db0ab8a.zip
New port, www/p5-Catalyst-Plugin-ConfigLoader, Load config files of various types
Notes
Notes: svn path=/head/; revision=167501
Diffstat (limited to 'www/p5-Catalyst-Plugin-ConfigLoader')
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader/Makefile36
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader/pkg-descr8
-rw-r--r--www/p5-Catalyst-Plugin-ConfigLoader/pkg-plist10
4 files changed, 57 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader/Makefile b/www/p5-Catalyst-Plugin-ConfigLoader/Makefile
new file mode 100644
index 000000000000..89434ac32f84
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-ConfigLoader
+# Date created: July 11, 2006
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-ConfigLoader
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Load config files of various types
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=0:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Data-Visitor>=0.02:${PORTSDIR}/devel/p5-Data-Visitor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::ConfigLoader.3 \
+ Catalyst::Plugin::ConfigLoader::General.3 \
+ Catalyst::Plugin::ConfigLoader::INI.3 \
+ Catalyst::Plugin::ConfigLoader::JSON.3 \
+ Catalyst::Plugin::ConfigLoader::Perl.3 \
+ Catalyst::Plugin::ConfigLoader::XML.3 \
+ Catalyst::Plugin::ConfigLoader::YAML.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader/distinfo b/www/p5-Catalyst-Plugin-ConfigLoader/distinfo
new file mode 100644
index 000000000000..2638324065d5
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-ConfigLoader-0.09.tar.gz) = 2f496087bb67a644c6c1a0b566c55fe8
+SHA256 (Catalyst-Plugin-ConfigLoader-0.09.tar.gz) = 98c49d574bf030a9d4fd503c3f2efa895029ad2d6863d84cdcee80439cf79ddc
+SIZE (Catalyst-Plugin-ConfigLoader-0.09.tar.gz) = 7608
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader/pkg-descr b/www/p5-Catalyst-Plugin-ConfigLoader/pkg-descr
new file mode 100644
index 000000000000..10a90fd0438d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader/pkg-descr
@@ -0,0 +1,8 @@
+This module will attempt to load find and load a configuration file of
+various types. Currently it supports YAML, JSON, XML, INI and Perl formats.
+
+To support the distinction between development and production environments,
+this module will also attemp to load a local config (e.g. myapp_local.yaml)
+which will override any duplicate settings.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-ConfigLoader/
diff --git a/www/p5-Catalyst-Plugin-ConfigLoader/pkg-plist b/www/p5-Catalyst-Plugin-ConfigLoader/pkg-plist
new file mode 100644
index 000000000000..2a7c4619a548
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-ConfigLoader/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Catalyst/Plugin/ConfigLoader.pm
+%%SITE_PERL%%/Catalyst/Plugin/ConfigLoader/General.pm
+%%SITE_PERL%%/Catalyst/Plugin/ConfigLoader/INI.pm
+%%SITE_PERL%%/Catalyst/Plugin/ConfigLoader/JSON.pm
+%%SITE_PERL%%/Catalyst/Plugin/ConfigLoader/Perl.pm
+%%SITE_PERL%%/Catalyst/Plugin/ConfigLoader/XML.pm
+%%SITE_PERL%%/Catalyst/Plugin/ConfigLoader/YAML.pm
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/ConfigLoader
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst