aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Session-Store-Memcached
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-01-02 11:44:51 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-01-02 11:44:51 +0000
commit00654bc55feb6df18286c418641a59e07eebeeb2 (patch)
tree2107d34300907b766ae380a18f9b31fb5626acc6 /www/p5-Catalyst-Plugin-Session-Store-Memcached
parent8d16e221bede849c65a1d1e3986aca7a5a4b6e05 (diff)
downloadports-00654bc55feb6df18286c418641a59e07eebeeb2.tar.gz
ports-00654bc55feb6df18286c418641a59e07eebeeb2.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-Store-Memcached')
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached/Makefile31
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached/pkg-descr5
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached/Makefile b/www/p5-Catalyst-Plugin-Session-Store-Memcached/Makefile
new file mode 100644
index 000000000000..8a4e5e4c724a
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-Memcached
+# Date created: 2 Jan 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-Memcached
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Memcached storage backend for session data
+
+BUILD_DEPENDS= p5-Catalyst>=5.0:${PORTSDIR}/www/p5-Catalyst \
+ p5-Cache-Memcached-Managed>=0:${PORTSDIR}/databases/p5-Cache-Memcached-Managed \
+ p5-Catalyst-Plugin-Session>=0.01:${PORTSDIR}/www/p5-Catalyst-Plugin-Session
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Session::Store::Memcached.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500801
+IGNORE= requires Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached/distinfo b/www/p5-Catalyst-Plugin-Session-Store-Memcached/distinfo
new file mode 100644
index 000000000000..813f0451fc1a
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-Store-Memcached-0.02.tar.gz) = e84aeb94978e10810383553c9bf91dd1
+SHA256 (Catalyst-Plugin-Session-Store-Memcached-0.02.tar.gz) = 2241052ae836a09e5ec967241bb000b4f2bf05112d6590d71d346793a7b68191
+SIZE (Catalyst-Plugin-Session-Store-Memcached-0.02.tar.gz) = 4199
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached/pkg-descr b/www/p5-Catalyst-Plugin-Session-Store-Memcached/pkg-descr
new file mode 100644
index 000000000000..9896cd3db579
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached/pkg-descr
@@ -0,0 +1,5 @@
+"Catalyst::Plugin::Session::Store::Memcached" is a session storage
+plugin for Catalyst that uses the Cache::Memcached::Managed module to
+connect to memcached, a fast data caching server.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-Memcached/
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached/pkg-plist b/www/p5-Catalyst-Plugin-Session-Store-Memcached/pkg-plist
new file mode 100644
index 000000000000..0e98ee2ccbc1
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store/Memcached.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Session 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true