aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Runtime/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-19 20:33:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-19 20:33:19 +0000
commitb8806b457b438d3211f6bb71597fd43d224f4a36 (patch)
tree11119b26405a1fccfc8eab70b3f7e67911146aba /www/p5-Catalyst-Runtime/Makefile
parent01a3d1040495a2afa2c1f4c8bb25d9369deac6c3 (diff)
Notes
Diffstat (limited to 'www/p5-Catalyst-Runtime/Makefile')
-rw-r--r--www/p5-Catalyst-Runtime/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/www/p5-Catalyst-Runtime/Makefile b/www/p5-Catalyst-Runtime/Makefile
index b3e44361dcce..53a45aa269ca 100644
--- a/www/p5-Catalyst-Runtime/Makefile
+++ b/www/p5-Catalyst-Runtime/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= Catalyst-Runtime
-PORTVERSION= 5.90011
+PORTVERSION= 5.90012
CATEGORIES= www perl5
MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:BOBTFISH
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= The Elegant MVC Web Application Framework (Runtime)
-BUILD_DEPENDS= p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
- p5-CGI-Simple>=1.109:${PORTSDIR}/www/p5-CGI-Simple \
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-CGI-Simple>=1.109:${PORTSDIR}/www/p5-CGI-Simple \
p5-Class-C3-Adopt-NEXT>=0.07:${PORTSDIR}/devel/p5-Class-C3-Adopt-NEXT \
p5-Class-Load>=0.12:${PORTSDIR}/devel/p5-Class-Load \
p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump \
p5-Data-OptList>=0:${PORTSDIR}/devel/p5-Data-OptList \
p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-HTTP-Body>=1.06:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-HTTP-Message>=5.814:${PORTSDIR}/www/p5-HTTP-Message \
p5-HTTP-Request-AsCGI>=1.0:${PORTSDIR}/www/p5-HTTP-Request-AsCGI \
p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat \
@@ -31,8 +35,8 @@ BUILD_DEPENDS= p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfSco
p5-MooseX-MethodAttributes>=0.24:${PORTSDIR}/devel/p5-MooseX-MethodAttributes \
p5-MooseX-Role-WithOverloading>=0.09:${PORTSDIR}/devel/p5-MooseX-Role-WithOverloading \
p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
- p5-MooseX-Types-LoadableClass>=0.003:${PORTSDIR}/devel/p5-MooseX-Types-LoadableClass \
p5-MooseX-Types-Common>=0:${PORTSDIR}/devel/p5-MooseX-Types-Common \
+ p5-MooseX-Types-LoadableClass>=0.003:${PORTSDIR}/devel/p5-MooseX-Types-LoadableClass \
p5-Path-Class>=0.09:${PORTSDIR}/devel/p5-Path-Class \
p5-Plack>=0.9974:${PORTSDIR}/www/p5-Plack \
p5-Plack-Middleware-ReverseProxy>=0.04:${PORTSDIR}/www/p5-Plack-Middleware-ReverseProxy \
@@ -47,13 +51,12 @@ BUILD_DEPENDS= p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfSco
p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-namespace-autoclean>=0.09:${PORTSDIR}/devel/p5-namespace-autoclean \
- p5-namespace-clean>=0.13:${PORTSDIR}/devel/p5-namespace-clean
+ p5-namespace-clean>=0.23:${PORTSDIR}/devel/p5-namespace-clean
RUN_DEPENDS:= ${BUILD_DEPENDS}
-BUILD_DEPENDS+= p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
- p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message
# Do not add p5-Catalyst-Engine-PSGI and p5-CatalystX-LeakChecker to TEST_DEPENDS to avoid cyclic dependencies in tinderbox
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+TEST_DEPENDS= p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Without-Module>=0:${PORTSDIR}/devel/p5-Test-Without-Module
PERL_CONFIGURE= yes