aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Dancer/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-04-16 13:55:15 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-04-16 13:55:15 +0000
commitdaa5ddad4ae6cc63f0507d44e4a7729fc1963bcb (patch)
tree93a87087b181a6ce8f797feac0f8b4529d7d4cd2 /www/p5-Dancer/Makefile
parent55cd7af66ea087baa1cfe46eb203a46514f24733 (diff)
downloadports-daa5ddad4ae6cc63f0507d44e4a7729fc1963bcb.tar.gz
ports-daa5ddad4ae6cc63f0507d44e4a7729fc1963bcb.zip
Notes
Diffstat (limited to 'www/p5-Dancer/Makefile')
-rw-r--r--www/p5-Dancer/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/www/p5-Dancer/Makefile b/www/p5-Dancer/Makefile
new file mode 100644
index 000000000000..61ac14992546
--- /dev/null
+++ b/www/p5-Dancer/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: Dancer
+# Date created: 16 Apr 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Dancer
+PORTVERSION= 1.175
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SU/SUKRIA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for minimal-effort oriented web application framework
+
+RUN_DEPENDS= \
+ p5-HTTP-Body>0:${PORTSDIR}/www/p5-HTTP-Body \
+ p5-HTTP-Server-Simple-PSGI>=0.11:${PORTSDIR}/www/p5-HTTP-Server-Simple-PSGI \
+ p5-MIME-Types>0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= dancer.1
+MAN3= Dancer.3 \
+ Dancer::Config.3 \
+ Dancer::Cookbook.3 \
+ Dancer::Deployment.3 \
+ Dancer::Engine.3 \
+ Dancer::Error.3 \
+ Dancer::HTTP.3 \
+ Dancer::Logger.3 \
+ Dancer::ModuleLoader.3 \
+ Dancer::Plugin.3 \
+ Dancer::Request.3 \
+ Dancer::Request::Upload.3 \
+ Dancer::Route::Cache.3 \
+ Dancer::Serializer.3 \
+ Dancer::Serializer::JSON.3 \
+ Dancer::Serializer::Mutable.3 \
+ Dancer::Serializer::YAML.3 \
+ Dancer::Session.3 \
+ Dancer::Session::Abstract.3 \
+ Dancer::Session::Simple.3 \
+ Dancer::Session::YAML.3 \
+ Dancer::Template.3 \
+ Dancer::Template::Abstract.3 \
+ Dancer::Template::Simple.3 \
+ Dancer::Template::TemplateToolkit.3
+
+.include <bsd.port.mk>