aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTML-Template-HashWrapper
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-09-15 18:31:01 +0000
committerLars Thegler <lth@FreeBSD.org>2005-09-15 18:31:01 +0000
commit9e0d15b0043020c989a41540e91f68ea16644c13 (patch)
tree76c3d3283e278b4465ae3e24ddb31ecc7c7bbe02 /www/p5-HTML-Template-HashWrapper
parent2d1af5211adf2aa43f39d941d927a5735c02ff80 (diff)
downloadports-9e0d15b0043020c989a41540e91f68ea16644c13.tar.gz
ports-9e0d15b0043020c989a41540e91f68ea16644c13.zip
Notes
Diffstat (limited to 'www/p5-HTML-Template-HashWrapper')
-rw-r--r--www/p5-HTML-Template-HashWrapper/Makefile31
-rw-r--r--www/p5-HTML-Template-HashWrapper/distinfo2
-rw-r--r--www/p5-HTML-Template-HashWrapper/pkg-descr3
-rw-r--r--www/p5-HTML-Template-HashWrapper/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-HTML-Template-HashWrapper/Makefile b/www/p5-HTML-Template-HashWrapper/Makefile
new file mode 100644
index 000000000000..64d28884aa6b
--- /dev/null
+++ b/www/p5-HTML-Template-HashWrapper/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-HTML-Template-HashWrapper
+# Date Created: 15 Sep 2005
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Template-HashWrapper
+PORTVERSION= 1.3
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Easy way to use the associate option from HTML::Template
+
+RUN_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Template::HashWrapper.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTML-Template-HashWrapper/distinfo b/www/p5-HTML-Template-HashWrapper/distinfo
new file mode 100644
index 000000000000..e44e0c93b51e
--- /dev/null
+++ b/www/p5-HTML-Template-HashWrapper/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTML-Template-HashWrapper-1.3.tar.gz) = eee47d1b8e86dd309539898f6afe458d
+SIZE (HTML-Template-HashWrapper-1.3.tar.gz) = 4973
diff --git a/www/p5-HTML-Template-HashWrapper/pkg-descr b/www/p5-HTML-Template-HashWrapper/pkg-descr
new file mode 100644
index 000000000000..f057a03dc639
--- /dev/null
+++ b/www/p5-HTML-Template-HashWrapper/pkg-descr
@@ -0,0 +1,3 @@
+A module to use the associate option from HTML::Template via hash references.
+
+WWW: http://search.cpan.org/~gregfast/HTML-Template-HashWrapper-1.3/
diff --git a/www/p5-HTML-Template-HashWrapper/pkg-plist b/www/p5-HTML-Template-HashWrapper/pkg-plist
new file mode 100644
index 000000000000..7e2bbdf5b566
--- /dev/null
+++ b/www/p5-HTML-Template-HashWrapper/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTML/Template/HashWrapper.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/HashWrapper/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template/HashWrapper
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML/Template 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true