aboutsummaryrefslogtreecommitdiff
path: root/www/p5-HTTP-WebTest
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-01-12 03:59:22 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-01-12 03:59:22 +0000
commit0e24dd17b14541bde8408ed527f765f3212f1487 (patch)
tree686ae1eaa7913909897ea8a7734e724f9d59e6e5 /www/p5-HTTP-WebTest
parenta9bafdd6c47d1c6f55c76063d6b883599b9b0061 (diff)
downloadports-0e24dd17b14541bde8408ed527f765f3212f1487.tar.gz
ports-0e24dd17b14541bde8408ed527f765f3212f1487.zip
Notes
Diffstat (limited to 'www/p5-HTTP-WebTest')
-rw-r--r--www/p5-HTTP-WebTest/Makefile54
-rw-r--r--www/p5-HTTP-WebTest/distinfo1
-rw-r--r--www/p5-HTTP-WebTest/pkg-comment1
-rw-r--r--www/p5-HTTP-WebTest/pkg-descr6
-rw-r--r--www/p5-HTTP-WebTest/pkg-plist34
5 files changed, 96 insertions, 0 deletions
diff --git a/www/p5-HTTP-WebTest/Makefile b/www/p5-HTTP-WebTest/Makefile
new file mode 100644
index 000000000000..54ebc489e1bd
--- /dev/null
+++ b/www/p5-HTTP-WebTest/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: p5-HTTP-WebTest
+# Date Created: 9 Jan, 2003
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-WebTest
+PORTVERSION= 2.00
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
+ ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/Test/Builder.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= wt.1
+MAN3= Bundle::HTTP::WebTest.3 \
+ HTTP::WebTest.3 HTTP::WebTest::API.3 \
+ HTTP::WebTest::Cookbook.3 HTTP::WebTest::Cookies.3 \
+ HTTP::WebTest::Parser.3 HTTP::WebTest::Plugin.3 \
+ HTTP::WebTest::Plugin::Click.3 \
+ HTTP::WebTest::Plugin::ContentSizeTest.3 \
+ HTTP::WebTest::Plugin::Cookies.3 \
+ HTTP::WebTest::Plugin::DefaultReport.3 \
+ HTTP::WebTest::Plugin::Delay.3 \
+ HTTP::WebTest::Plugin::HarnessReport.3 \
+ HTTP::WebTest::Plugin::Hooks.3 \
+ HTTP::WebTest::Plugin::Loader.3 \
+ HTTP::WebTest::Plugin::ResponseTimeTest.3 \
+ HTTP::WebTest::Plugin::SetRequest.3 \
+ HTTP::WebTest::Plugin::StatusTest.3 \
+ HTTP::WebTest::Plugin::TextMatchTest.3 \
+ HTTP::WebTest::Plugins.3 HTTP::WebTest::ReportPlugin.3 \
+ HTTP::WebTest::Request.3 HTTP::WebTest::SelfTest.3 \
+ HTTP::WebTest::Test.3 HTTP::WebTest::TestResult.3 \
+ HTTP::WebTest::Utils.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-WebTest/distinfo b/www/p5-HTTP-WebTest/distinfo
new file mode 100644
index 000000000000..d5e398b42b5d
--- /dev/null
+++ b/www/p5-HTTP-WebTest/distinfo
@@ -0,0 +1 @@
+MD5 (HTTP-WebTest-2.00.tar.gz) = e93464263f7cd321c8b43fa7c73604e0
diff --git a/www/p5-HTTP-WebTest/pkg-comment b/www/p5-HTTP-WebTest/pkg-comment
new file mode 100644
index 000000000000..53fadc0dd7f7
--- /dev/null
+++ b/www/p5-HTTP-WebTest/pkg-comment
@@ -0,0 +1 @@
+Tests remote URLs or local web files
diff --git a/www/p5-HTTP-WebTest/pkg-descr b/www/p5-HTTP-WebTest/pkg-descr
new file mode 100644
index 000000000000..a4b6335b1f0d
--- /dev/null
+++ b/www/p5-HTTP-WebTest/pkg-descr
@@ -0,0 +1,6 @@
+HTTP-WebTest tests remote URLs or local web files.
+
+This module runs tests on remote URLs or local web files containing
+Perl/JSP/HTML/JavaScript/etc. and generates a detailed test report.
+
+WWW: http://martynov.org/webtest/
diff --git a/www/p5-HTTP-WebTest/pkg-plist b/www/p5-HTTP-WebTest/pkg-plist
new file mode 100644
index 000000000000..db9bad1a7711
--- /dev/null
+++ b/www/p5-HTTP-WebTest/pkg-plist
@@ -0,0 +1,34 @@
+bin/wt
+%%SITE_PERL%%/Bundle/HTTP/WebTest.pm
+%%SITE_PERL%%/HTTP/WebTest.pm
+%%SITE_PERL%%/HTTP/WebTest.pm.in
+%%SITE_PERL%%/HTTP/WebTest/API.pm
+%%SITE_PERL%%/HTTP/WebTest/Cookbook.pod
+%%SITE_PERL%%/HTTP/WebTest/Cookies.pm
+%%SITE_PERL%%/HTTP/WebTest/Parser.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/Click.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/ContentSizeTest.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/Cookies.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/DefaultReport.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/Delay.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/HarnessReport.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/Hooks.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/Loader.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/ResponseTimeTest.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/SetRequest.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/StatusTest.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugin/TextMatchTest.pm
+%%SITE_PERL%%/HTTP/WebTest/Plugins.pod
+%%SITE_PERL%%/HTTP/WebTest/ReportPlugin.pm
+%%SITE_PERL%%/HTTP/WebTest/Request.pm
+%%SITE_PERL%%/HTTP/WebTest/SelfTest.pm
+%%SITE_PERL%%/HTTP/WebTest/Test.pm
+%%SITE_PERL%%/HTTP/WebTest/TestResult.pm
+%%SITE_PERL%%/HTTP/WebTest/Utils.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/WebTest/.packlist
+@dirrm %%SITE_PERL%%/Bundle/HTTP
+@dirrm %%SITE_PERL%%/HTTP/WebTest/Plugin
+@dirrm %%SITE_PERL%%/HTTP/WebTest
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/WebTest
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP