aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Image-Delivery/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-29 08:31:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-29 08:31:21 +0000
commit88d1f47e2598e6951afa28b3353556082575c17a (patch)
treeb72bcac8f6ae460e15cfebe2a0590a4a35df42c0 /www/p5-Image-Delivery/Makefile
parent412cbb25c1b7b474d16e2d697643488f0281126b (diff)
Notes
Diffstat (limited to 'www/p5-Image-Delivery/Makefile')
-rw-r--r--www/p5-Image-Delivery/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/p5-Image-Delivery/Makefile b/www/p5-Image-Delivery/Makefile
new file mode 100644
index 000000000000..7ff4fb1caed2
--- /dev/null
+++ b/www/p5-Image-Delivery/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Image-Delivery
+# Date created: 08 September 2007
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image-Delivery
+PORTVERSION= 0.13
+CATEGORIES= www graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Image
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= coryking@mozimedia.com
+COMMENT= Efficient transformation and delivery of web images
+
+BUILD_DEPENDS= p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-TransformPath>=1.00:${PORTSDIR}/devel/p5-Digest-TransformPath \
+ p5-HTML-Location>=1.01:${PORTSDIR}/www/p5-HTML-Location \
+ p5-File-Remove>=0.37:${PORTSDIR}/devel/p5-File-Remove \
+ p5-File-Slurp>=9999.12:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools \
+ p5-Scalar-List-Utils>=1.19:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Params-Coerce>=0.14:${PORTSDIR}/devel/p5-Params-Coerce
+RUN_DEPENDS= p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-TransformPath>=1.00:${PORTSDIR}/devel/p5-Digest-TransformPath \
+ p5-HTML-Location>=1.01:${PORTSDIR}/www/p5-HTML-Location \
+ p5-File-Remove>=0.37:${PORTSDIR}/devel/p5-File-Remove \
+ p5-File-Slurp>=9999.12:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools \
+ p5-Scalar-List-Utils>=1.19:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Params-Coerce>=0.14:${PORTSDIR}/devel/p5-Params-Coerce
+
+PERL_CONFIGURE= yes
+
+MAN3= Image::Delivery.3 Image::Delivery::Provider.3
+
+.include <bsd.port.mk>