aboutsummaryrefslogtreecommitdiff
path: root/www/p5-LWP-Authen-Wsse
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-16 02:25:44 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-16 02:25:44 +0000
commit64d9c2bb8c5d7ebeaa062dfdf032958514e2a572 (patch)
treec8c739b3a894a3a5c935b3ac92ecdebdf6f1e623 /www/p5-LWP-Authen-Wsse
parentabe6243d4e34cc1aca96a4cfa98b4f8e0eb6001a (diff)
Add p5-LWP-Authen-Wsse 0.03, library for enabling X-WSSE authentication
in LWP. PR: ports/68224 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Notes
Notes: svn path=/head/; revision=113748
Diffstat (limited to 'www/p5-LWP-Authen-Wsse')
-rw-r--r--www/p5-LWP-Authen-Wsse/Makefile27
-rw-r--r--www/p5-LWP-Authen-Wsse/distinfo2
-rw-r--r--www/p5-LWP-Authen-Wsse/pkg-descr11
-rw-r--r--www/p5-LWP-Authen-Wsse/pkg-plist6
4 files changed, 46 insertions, 0 deletions
diff --git a/www/p5-LWP-Authen-Wsse/Makefile b/www/p5-LWP-Authen-Wsse/Makefile
new file mode 100644
index 000000000000..117c3347208a
--- /dev/null
+++ b/www/p5-LWP-Authen-Wsse/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-LWP-Authen-Wsse
+# Date created: Wed Jun 23 15:15:30 CST 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-Authen-Wsse
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= LWP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@freebsd.org
+COMMENT= Library for enabling X-WSSE authentication in LWP
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Authen::Wsse.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-LWP-Authen-Wsse/distinfo b/www/p5-LWP-Authen-Wsse/distinfo
new file mode 100644
index 000000000000..ec019217cb1a
--- /dev/null
+++ b/www/p5-LWP-Authen-Wsse/distinfo
@@ -0,0 +1,2 @@
+MD5 (LWP-Authen-Wsse-0.03.tar.gz) = 01543381a1a5adce2cd4d4213e939b97
+SIZE (LWP-Authen-Wsse-0.03.tar.gz) = 10456
diff --git a/www/p5-LWP-Authen-Wsse/pkg-descr b/www/p5-LWP-Authen-Wsse/pkg-descr
new file mode 100644
index 000000000000..cdb62d04eafb
--- /dev/null
+++ b/www/p5-LWP-Authen-Wsse/pkg-descr
@@ -0,0 +1,11 @@
+LWP::Authen::Wsse allows LWP to authenticate against servers that are using
+the X-WSSE authentication scheme, as required by the Atom Authentication API.
+
+The module is used indirectly through LWP, rather than including it directly
+in your code. The LWP system will invoke the WSSE authentication when it
+encounters the authentication scheme while attempting to retrieve a URL
+from a server.
+
+WWW: http://search.cpan.org/dist/LWP-Authen-Wsse/
+
+Author: Autrijus Tang <autrijus@autrijus.org>
diff --git a/www/p5-LWP-Authen-Wsse/pkg-plist b/www/p5-LWP-Authen-Wsse/pkg-plist
new file mode 100644
index 000000000000..2434e4eca574
--- /dev/null
+++ b/www/p5-LWP-Authen-Wsse/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/LWP/Authen/Wsse.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Authen/Wsse/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/Authen 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LWP/Authen 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LWP 2>/dev/null || true