aboutsummaryrefslogtreecommitdiff
path: root/www/p5-LWP-Protocol-https/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-11 06:03:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-11 06:03:31 +0000
commit626f63a0e4b0ad40f1f24fb777e109e96922c6c3 (patch)
tree052d37327923ee7b753a2ca51413b8dd925ad464 /www/p5-LWP-Protocol-https/Makefile
parent99765ada6a01c8ddf0a51326e03675d1cba3eb7e (diff)
downloadports-626f63a0e4b0ad40f1f24fb777e109e96922c6c3.tar.gz
ports-626f63a0e4b0ad40f1f24fb777e109e96922c6c3.zip
Notes
Diffstat (limited to 'www/p5-LWP-Protocol-https/Makefile')
-rw-r--r--www/p5-LWP-Protocol-https/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-LWP-Protocol-https/Makefile b/www/p5-LWP-Protocol-https/Makefile
new file mode 100644
index 000000000000..39d951eed7ad
--- /dev/null
+++ b/www/p5-LWP-Protocol-https/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-LWP-Protocol-https
+# Date created: 2011-06-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-Protocol-https
+PORTVERSION= 6.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Provide https support for LWP::UserAgent
+
+# We remove p5-libwww here to avoid cyclic dependency
+RUN_DEPENDS= p5-IO-Socket-SSL>=1.38:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Mozilla-CA>=20110101:${PORTSDIR}/www/p5-Mozilla-CA \
+ p5-Net-HTTP>=6:${PORTSDIR}/net/p5-Net-HTTP
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Protocol::https.3
+
+.include <bsd.port.mk>