aboutsummaryrefslogtreecommitdiff
path: root/www/p5-MasonX-Request-WithApacheSession/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-12 17:48:32 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-12 17:48:32 +0000
commita4e17cb4c6339960156502759dfe720f82b6ae65 (patch)
tree505e687d7226b724586081ccbdfbbb331adae2b3 /www/p5-MasonX-Request-WithApacheSession/Makefile
parent57d98c6a8c9f20238d1027b51b19f779689c519e (diff)
downloadports-a4e17cb4c6339960156502759dfe720f82b6ae65.tar.gz
ports-a4e17cb4c6339960156502759dfe720f82b6ae65.zip
Notes
Diffstat (limited to 'www/p5-MasonX-Request-WithApacheSession/Makefile')
-rw-r--r--www/p5-MasonX-Request-WithApacheSession/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/p5-MasonX-Request-WithApacheSession/Makefile b/www/p5-MasonX-Request-WithApacheSession/Makefile
new file mode 100644
index 000000000000..44309e95fb40
--- /dev/null
+++ b/www/p5-MasonX-Request-WithApacheSession/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-MasonX-Request-WithApacheSession
+# Date created: 2003.07.21
+# Whom: Nick Hilliard <nick@foobar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MasonX-Request-WithApacheSession
+PORTVERSION= 0.21
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MasonX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nick@foobar.org
+COMMENT= An interface to Apache::Session for HTML::Mason
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
+ ${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MasonX::Request::WithApacheSession.3
+
+.include <bsd.port.pre.mk>
+
+# Depends on devel/p5-Class-Container whichs needs perl 5.6.x or later
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>