aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Net-FreshBooks-API
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2010-11-22 13:57:14 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2010-11-22 13:57:14 +0000
commit0bfe77010a619d1930c8787f7f1f36f76eca0dff (patch)
tree56e43ee131a78d847c2836a94a33999a9ac797c4 /www/p5-Net-FreshBooks-API
parentf80d1da1f4c660dc936e06122500d6dd3e2b023a (diff)
downloadports-0bfe77010a619d1930c8787f7f1f36f76eca0dff.tar.gz
ports-0bfe77010a619d1930c8787f7f1f36f76eca0dff.zip
Notes
Diffstat (limited to 'www/p5-Net-FreshBooks-API')
-rw-r--r--www/p5-Net-FreshBooks-API/Makefile21
-rw-r--r--www/p5-Net-FreshBooks-API/distinfo4
-rw-r--r--www/p5-Net-FreshBooks-API/pkg-plist3
3 files changed, 16 insertions, 12 deletions
diff --git a/www/p5-Net-FreshBooks-API/Makefile b/www/p5-Net-FreshBooks-API/Makefile
index c0e55315d67b..556c20a87e20 100644
--- a/www/p5-Net-FreshBooks-API/Makefile
+++ b/www/p5-Net-FreshBooks-API/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-FreshBooks-API
-PORTVERSION= 0.17
+PORTVERSION= 0.18
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -24,20 +24,15 @@ RUN_DEPENDS= p5-Clone>=0:${PORTSDIR}/devel/p5-Clone \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
- p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
- p5-Sub-Override>=0:${PORTSDIR}/devel/p5-Sub-Override \
- p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
- p5-Test-WWW-Mechanize>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize \
- p5-Test-XML>=0:${PORTSDIR}/devel/p5-Test-XML
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
PERL_MODBUILD= yes
MAN3= Net::FreshBooks::API.3 \
Net::FreshBooks::API::Base.3 \
Net::FreshBooks::API::Client.3 \
+ Net::FreshBooks::API::Error.3 \
Net::FreshBooks::API::Estimate.3 \
Net::FreshBooks::API::Invoice.3 \
Net::FreshBooks::API::InvoiceLine.3 \
@@ -50,4 +45,10 @@ MAN3= Net::FreshBooks::API.3 \
Net::FreshBooks::API::Role::LineItem.3 \
Net::FreshBooks::API::Role::SendBy.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501104
+BUILD_DEPENDS+= p5-Module-Build>=0.3601:${PORTSDIR}/devel/p5-Module-Build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Net-FreshBooks-API/distinfo b/www/p5-Net-FreshBooks-API/distinfo
index febf999e1ec5..19cfc2b61dca 100644
--- a/www/p5-Net-FreshBooks-API/distinfo
+++ b/www/p5-Net-FreshBooks-API/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Net-FreshBooks-API-0.17.tar.gz) = 9bb139a8823c7de8045968f46cfcdda4817f55f4b7c2930954c5ec09f2545048
-SIZE (Net-FreshBooks-API-0.17.tar.gz) = 37560
+SHA256 (Net-FreshBooks-API-0.18.tar.gz) = 5330d8095757dc9f0bec6aac433a77a8224f46f3925149c20dab1a7e7b521eb0
+SIZE (Net-FreshBooks-API-0.18.tar.gz) = 38500
diff --git a/www/p5-Net-FreshBooks-API/pkg-plist b/www/p5-Net-FreshBooks-API/pkg-plist
index dd86c96d7471..9ee6d72a3ef7 100644
--- a/www/p5-Net-FreshBooks-API/pkg-plist
+++ b/www/p5-Net-FreshBooks-API/pkg-plist
@@ -1,6 +1,8 @@
+@comment $FreeBSD$
%%SITE_PERL%%/Net/FreshBooks/API.pm
%%SITE_PERL%%/Net/FreshBooks/API/Base.pm
%%SITE_PERL%%/Net/FreshBooks/API/Client.pm
+%%SITE_PERL%%/Net/FreshBooks/API/Error.pm
%%SITE_PERL%%/Net/FreshBooks/API/Estimate.pm
%%SITE_PERL%%/Net/FreshBooks/API/Invoice.pm
%%SITE_PERL%%/Net/FreshBooks/API/InvoiceLine.pm
@@ -15,3 +17,4 @@
@dirrmtry %%SITE_PERL%%/Net/FreshBooks/API/Role
@dirrmtry %%SITE_PERL%%/Net/FreshBooks/API
@dirrmtry %%SITE_PERL%%/Net/FreshBooks
+@dirrmtry %%SITE_PERL%%/Net