aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Net-FreshBooks-API
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-04 22:56:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-04 22:56:48 +0000
commitd998c15812f606ac24a387178d9d1de89a403a08 (patch)
tree47ccbc9081ad58b1fb1dc38fbaa772260ce6c05c /www/p5-Net-FreshBooks-API
parentf6931ff3ddba7ba89fe63c73d4198973f907882a (diff)
downloadports-d998c15812f606ac24a387178d9d1de89a403a08.tar.gz
ports-d998c15812f606ac24a387178d9d1de89a403a08.zip
Notes
Diffstat (limited to 'www/p5-Net-FreshBooks-API')
-rw-r--r--www/p5-Net-FreshBooks-API/Makefile36
-rw-r--r--www/p5-Net-FreshBooks-API/distinfo3
-rw-r--r--www/p5-Net-FreshBooks-API/pkg-descr6
-rw-r--r--www/p5-Net-FreshBooks-API/pkg-plist16
4 files changed, 61 insertions, 0 deletions
diff --git a/www/p5-Net-FreshBooks-API/Makefile b/www/p5-Net-FreshBooks-API/Makefile
new file mode 100644
index 000000000000..7f3b5ce8ee58
--- /dev/null
+++ b/www/p5-Net-FreshBooks-API/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Net-FreshBooks-API
+# Date created: 2010-01-03
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-FreshBooks-API
+PORTVERSION= 0.10
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Easy OO access to the FreshBooks.com API
+
+RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Clone>0:${PORTSDIR}/devel/p5-Clone \
+ p5-Crypt-SSLeay>0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-Data-Dump>0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Lingua-EN-Inflect>0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect \
+ p5-Path-Class>0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::FreshBooks::API.3 \
+ Net::FreshBooks::API::Base.3 \
+ Net::FreshBooks::API::Iterator.3 \
+ Net::FreshBooks::API::Recurring.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Net-FreshBooks-API/distinfo b/www/p5-Net-FreshBooks-API/distinfo
new file mode 100644
index 000000000000..fcb414acbcf1
--- /dev/null
+++ b/www/p5-Net-FreshBooks-API/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-FreshBooks-API-0.10.tar.gz) = ce208cd35120c5a7b4ca1a22c6b0b357
+SHA256 (Net-FreshBooks-API-0.10.tar.gz) = 32633ee839eb3164d19bf8238cccdef117d9e76f7caca2d92bc1eede7e167057
+SIZE (Net-FreshBooks-API-0.10.tar.gz) = 17973
diff --git a/www/p5-Net-FreshBooks-API/pkg-descr b/www/p5-Net-FreshBooks-API/pkg-descr
new file mode 100644
index 000000000000..364c40ee2908
--- /dev/null
+++ b/www/p5-Net-FreshBooks-API/pkg-descr
@@ -0,0 +1,6 @@
+http://www.freshbooks.com is a website that lets you create, send and
+manage invoices. This module is an OO abstraction of their API that
+lets you work with Clients, Invoices etc as if they were standard Perl
+objects.
+
+WWW: http://search.cpan.org/dist/Net-FreshBooks-API/
diff --git a/www/p5-Net-FreshBooks-API/pkg-plist b/www/p5-Net-FreshBooks-API/pkg-plist
new file mode 100644
index 000000000000..8051b6620383
--- /dev/null
+++ b/www/p5-Net-FreshBooks-API/pkg-plist
@@ -0,0 +1,16 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FreshBooks/API/.packlist
+%%SITE_PERL%%/Net/FreshBooks/API.pm
+%%SITE_PERL%%/Net/FreshBooks/API/Base.pm
+%%SITE_PERL%%/Net/FreshBooks/API/Client.pm
+%%SITE_PERL%%/Net/FreshBooks/API/Invoice.pm
+%%SITE_PERL%%/Net/FreshBooks/API/InvoiceLine.pm
+%%SITE_PERL%%/Net/FreshBooks/API/Iterator.pm
+%%SITE_PERL%%/Net/FreshBooks/API/Links.pm
+%%SITE_PERL%%/Net/FreshBooks/API/Payment.pm
+%%SITE_PERL%%/Net/FreshBooks/API/Recurring.pm
+@dirrmtry %%SITE_PERL%%/Net/FreshBooks/API
+@dirrmtry %%SITE_PERL%%/Net/FreshBooks
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FreshBooks/API
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/FreshBooks
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net