aboutsummaryrefslogtreecommitdiff
path: root/www/p5-POE-Component-Server-SOAP
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-10-12 19:45:14 +0000
committerLars Thegler <lth@FreeBSD.org>2005-10-12 19:45:14 +0000
commite61551d1e064e31d3f8541506e7ee29e24a9429d (patch)
treebcde1c694d199881b141754e463c0e626f406f49 /www/p5-POE-Component-Server-SOAP
parent4ccc05ef3a5e0d260d296a1c5610f167bc5acb28 (diff)
downloadports-e61551d1e064e31d3f8541506e7ee29e24a9429d.tar.gz
ports-e61551d1e064e31d3f8541506e7ee29e24a9429d.zip
Notes
Diffstat (limited to 'www/p5-POE-Component-Server-SOAP')
-rw-r--r--www/p5-POE-Component-Server-SOAP/Makefile41
-rw-r--r--www/p5-POE-Component-Server-SOAP/distinfo2
-rw-r--r--www/p5-POE-Component-Server-SOAP/pkg-descr3
-rw-r--r--www/p5-POE-Component-Server-SOAP/pkg-plist11
4 files changed, 57 insertions, 0 deletions
diff --git a/www/p5-POE-Component-Server-SOAP/Makefile b/www/p5-POE-Component-Server-SOAP/Makefile
new file mode 100644
index 000000000000..163b2a6c5dff
--- /dev/null
+++ b/www/p5-POE-Component-Server-SOAP/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: www/p5-POE-Component-Server-SOAP
+# Date created: 12 October 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Server-SOAP
+PORTVERSION= 1.08
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Publish POE event handlers via SOAP over HTTP
+
+BUILD_DEPENDS= ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite \
+ ${SITE_PERL}/POE/Component/Server/SimpleHTTP.pm:${PORTSDIR}/www/p5-POE-Component-Server-SimpleHTTP \
+ ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Server::SOAP.3 \
+ POE::Component::Server::SOAP::Response.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' \
+ -e '$$_ = "" if /use warnings/;' \
+ ${WRKSRC}/lib/POE/Component/Server/SOAP.pm \
+ ${WRKSRC}/lib/POE/Component/Server/SOAP/Response.pm
+# @${PERL} -pi -e '$$_ = "" if /use warnings/;' \
+# -e '$$_ = "" if /ABSTRACT_FROM/;' \
+# -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' \
+# ${WRKSRC}/Makefile.PL \
+# ${WRKSRC}/lib/Class/DBI/DATA/Schema.pm
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-POE-Component-Server-SOAP/distinfo b/www/p5-POE-Component-Server-SOAP/distinfo
new file mode 100644
index 000000000000..313e522efbcc
--- /dev/null
+++ b/www/p5-POE-Component-Server-SOAP/distinfo
@@ -0,0 +1,2 @@
+MD5 (POE-Component-Server-SOAP-1.08.tar.gz) = f6a339133ff1fa84ec1829750da04314
+SIZE (POE-Component-Server-SOAP-1.08.tar.gz) = 12745
diff --git a/www/p5-POE-Component-Server-SOAP/pkg-descr b/www/p5-POE-Component-Server-SOAP/pkg-descr
new file mode 100644
index 000000000000..6f50a27d793f
--- /dev/null
+++ b/www/p5-POE-Component-Server-SOAP/pkg-descr
@@ -0,0 +1,3 @@
+This module makes serving SOAP/1.1 requests a breeze in POE.
+
+WWW: http://search.cpan.org/dist/POE-Component-Server-SOAP/
diff --git a/www/p5-POE-Component-Server-SOAP/pkg-plist b/www/p5-POE-Component-Server-SOAP/pkg-plist
new file mode 100644
index 000000000000..c1fe327c9f01
--- /dev/null
+++ b/www/p5-POE-Component-Server-SOAP/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/POE/Component/Server/SOAP.pm
+%%SITE_PERL%%/POE/Component/Server/SOAP/Response.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/SOAP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/SOAP
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component/Server/SOAP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true