aboutsummaryrefslogtreecommitdiff
path: root/www/p5-ParallelUserAgent
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-31 13:34:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-31 13:34:16 +0000
commit905f8e58f78043b36c679e966ad404b47e9c953a (patch)
tree558612b6b84e9acb58538c02d7e868fa3fc3fecd /www/p5-ParallelUserAgent
parent50cfb62e88d8136f6cf7d715739d3606d61c1fa6 (diff)
downloadports-905f8e58f78043b36c679e966ad404b47e9c953a.tar.gz
ports-905f8e58f78043b36c679e966ad404b47e9c953a.zip
Notes
Diffstat (limited to 'www/p5-ParallelUserAgent')
-rw-r--r--www/p5-ParallelUserAgent/Makefile30
-rw-r--r--www/p5-ParallelUserAgent/distinfo2
-rw-r--r--www/p5-ParallelUserAgent/pkg-descr19
-rw-r--r--www/p5-ParallelUserAgent/pkg-plist20
4 files changed, 71 insertions, 0 deletions
diff --git a/www/p5-ParallelUserAgent/Makefile b/www/p5-ParallelUserAgent/Makefile
new file mode 100644
index 000000000000..0414a271b1e3
--- /dev/null
+++ b/www/p5-ParallelUserAgent/Makefile
@@ -0,0 +1,30 @@
+# Created by: ache@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= ParallelUserAgent
+PORTVERSION= 2.57
+PORTREVISION= 3
+CATEGORIES= www perl5
+MASTER_SITES= CPAN/LWP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Extension for LWP to allow parallel HTTP and FTP access
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-HTML-Parser>=0:www/p5-HTML-Parser \
+ p5-URI>=0:net/p5-URI \
+ p5-libwww>=0:www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+REINPLACE_ARGS= -i ''
+USE_PERL5= configure
+USES= perl5
+
+post-patch:
+ @${REINPLACE_CMD} -e '/protocol->parse_head/d' ${WRKSRC}/lib/LWP/Parallel/UserAgent.pm
+
+.include <bsd.port.mk>
diff --git a/www/p5-ParallelUserAgent/distinfo b/www/p5-ParallelUserAgent/distinfo
new file mode 100644
index 000000000000..4d342cb66c14
--- /dev/null
+++ b/www/p5-ParallelUserAgent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ParallelUserAgent-2.57.tar.gz) = 9c350aeaab766080a53be25527495b52d563dc5c9515b8b2feea7f5bcd80c2c6
+SIZE (ParallelUserAgent-2.57.tar.gz) = 55375
diff --git a/www/p5-ParallelUserAgent/pkg-descr b/www/p5-ParallelUserAgent/pkg-descr
new file mode 100644
index 000000000000..116044a19abb
--- /dev/null
+++ b/www/p5-ParallelUserAgent/pkg-descr
@@ -0,0 +1,19 @@
+ParallelUserAgent (or PUA for short) is an extension of the existing libwww-5.x
+distribution. It allows you to connect to download several Web pages in
+_parallel_, without having to request each page one after the other.
+
+Instead of retrieving each single page using LWP::UserAgent::request or
+::simple_request methods, you first "register" all pages that you wish to
+download in parallel and then call PUA's "wait" method, which will then make all
+the necessary connections and download the pages.
+
+You can define callback routines which will be called whenever a connection is
+established, is cut off, new data comes in or a request finishes. The
+subroutines can be global for all requests you registered, or different for
+every single request.
+
+Callbacks for example allow you to print status updates as the responses come
+in, or even immediately post follow-up requests based on the responses, all
+within the same single "wait" cycle.
+
+WWW: http://search.cpan.org/dist/ParallelUserAgent/
diff --git a/www/p5-ParallelUserAgent/pkg-plist b/www/p5-ParallelUserAgent/pkg-plist
new file mode 100644
index 000000000000..8a5a9882d79a
--- /dev/null
+++ b/www/p5-ParallelUserAgent/pkg-plist
@@ -0,0 +1,20 @@
+%%SITE_PERL%%/Bundle/ParallelUA.pm
+%%SITE_PERL%%/LWP/Parallel.pm
+%%SITE_PERL%%/LWP/Parallel/Protocol.pm
+%%SITE_PERL%%/LWP/Parallel/Protocol/file.pm
+%%SITE_PERL%%/LWP/Parallel/Protocol/ftp.pm
+%%SITE_PERL%%/LWP/Parallel/Protocol/http.pm
+%%SITE_PERL%%/LWP/Parallel/Protocol/https.pm
+%%SITE_PERL%%/LWP/Parallel/RobotUA.pm
+%%SITE_PERL%%/LWP/Parallel/UserAgent.pm
+%%SITE_PERL%%/LWP/ParallelUA.pm
+%%SITE_PERL%%/LWP/RobotPUA.pm
+%%PERL5_MAN3%%/Bundle::ParallelUA.3.gz
+%%PERL5_MAN3%%/LWP::Parallel.3.gz
+%%PERL5_MAN3%%/LWP::Parallel::Protocol.3.gz
+%%PERL5_MAN3%%/LWP::Parallel::Protocol::ftp.3.gz
+%%PERL5_MAN3%%/LWP::Parallel::Protocol::http.3.gz
+%%PERL5_MAN3%%/LWP::Parallel::RobotUA.3.gz
+%%PERL5_MAN3%%/LWP::Parallel::UserAgent.3.gz
+%%PERL5_MAN3%%/LWP::ParallelUA.3.gz
+%%PERL5_MAN3%%/LWP::RobotPUA.3.gz