aboutsummaryrefslogtreecommitdiff
path: root/www/p5-RT-Authen-ExternalAuth
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-10-18 15:56:02 +0000
committerFlorian Smeets <flo@FreeBSD.org>2011-10-18 15:56:02 +0000
commit7371daa2cd60f69cef941838f8bb762dacfecade (patch)
tree044fa638485991128f3430c31bbcd95babc5608e /www/p5-RT-Authen-ExternalAuth
parent558aa8bae46d1a3e92fd456007842484cd0ab14e (diff)
downloadports-7371daa2cd60f69cef941838f8bb762dacfecade.tar.gz
ports-7371daa2cd60f69cef941838f8bb762dacfecade.zip
Notes
Diffstat (limited to 'www/p5-RT-Authen-ExternalAuth')
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile31
1 files changed, 23 insertions, 8 deletions
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
index ea5633d58a54..3d18bdc99c00 100644
--- a/www/p5-RT-Authen-ExternalAuth/Makefile
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -7,6 +7,7 @@
PORTNAME= RT-Authen-ExternalAuth
DISTVERSION= 0.09
+PORTREVISION= 1
CATEGORIES= www net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:FALCONE
@@ -15,26 +16,40 @@ PKGNAMEPREFIX= p5-
MAINTAINER= m.seaman@infracaninophile.co.uk
COMMENT= RT extension to authenticate users against an external source
-BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
-RUN_DEPENDS= ${BUILD_DEPENDS}
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
+ p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
+ p5-Net-SSLeay>0:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-RTHOME?= share/rt38
-RT_PM_DIR= ${SITE_PERL}
-BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt38
+OPTIONS= RT38 "Install for rt-3.8.x (default rt-4.0.x)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_RT38)
+RT_VER= 38
+.else
+RT_VER= 40
+.endif
+
+BUILD_DEPENDS+= ${SITE_PERL}/RT.pm:${PORTSDIR}/www/rt${RT_VER}
+RUN_DEPENDS+= ${SITE_PERL}/RT.pm:${PORTSDIR}/www/rt${RT_VER}
+
MAN3PREFIX= ${PREFIX}
MAN3= RT::Authen::ExternalAuth.3
-PLIST_SUB+= RTHOME=${RTHOME}
+PLIST_SUB+= RTHOME=share/rt${RT_VER}
# Note: You can install using an arbitrary $PREFIX but only if it
-# matches the $PREFIX used to install www/rt3{6,8}. Hence ignore
+# matches the $PREFIX used to install www/rt{38,40}. Hence ignore
# $PREFIX in the environment and inherit settings from RT.pm
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
unset PREFIX && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${RT_PM_DIR} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
.include <bsd.port.mk>