aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Search-MSN/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-15 08:50:35 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-15 08:50:35 +0000
commitcde8ec0cfae283f7c8f373ac63c9033d3555b407 (patch)
tree567e0fdf79eaa6986e1c019016e6ce37c83c8070 /www/p5-WWW-Search-MSN/Makefile
parenta7f0998653030b0238740e9afdc6b169b13ddbcb (diff)
Notes
Diffstat (limited to 'www/p5-WWW-Search-MSN/Makefile')
-rw-r--r--www/p5-WWW-Search-MSN/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/www/p5-WWW-Search-MSN/Makefile b/www/p5-WWW-Search-MSN/Makefile
new file mode 100644
index 000000000000..140a366773e7
--- /dev/null
+++ b/www/p5-WWW-Search-MSN/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-WWW-Search-MSN
+# Date created: 2006-07-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Search-MSN
+PORTVERSION= 0.0102
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Backend for searching search.msn.com
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/WWW/Search.pm:${PORTSDIR}/www/p5-WWW-Search
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Search::MSN.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-WWW-Search
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.if ${PERL_LEVEL} < 500701
+BUILD_DEPENDS+= ${SITE_PERL}/Encode.pm:${PORTSDIR}/converters/p5-Encode
+.endif
+
+.if ${PERL_LEVEL} < 500702
+BUILD_DEPENDS+= ${SITE_PERL}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>