aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Search/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-13 12:28:23 +0000
commit927c9c2190303cbf488da40b21aa8f687198bb23 (patch)
treeb50875b389c063d1bcadc768e710973b1992efd2 /www/p5-WWW-Search/Makefile
parent2a6d3bd8e2df3f99bd5bc37be426951c272419b9 (diff)
downloadports-927c9c2190303cbf488da40b21aa8f687198bb23.tar.gz
ports-927c9c2190303cbf488da40b21aa8f687198bb23.zip
Notes
Diffstat (limited to 'www/p5-WWW-Search/Makefile')
-rw-r--r--www/p5-WWW-Search/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/www/p5-WWW-Search/Makefile b/www/p5-WWW-Search/Makefile
index 86f6494a7643..f4201c4507b5 100644
--- a/www/p5-WWW-Search/Makefile
+++ b/www/p5-WWW-Search/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP.pm:${PORTSDIR}/w
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Inline.pm:${PORTSDIR}/devel/p5-Test-Inline \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/User.pm:${PORTSDIR}/sysutils/p5-User \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
@@ -30,7 +29,6 @@ PERL_CONFIGURE= yes
MAN1= AutoSearch.1 \
WebSearch.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= WWW::Search.3 \
WWW::SearchResult.3 \
WWW::Search::Null.3 \
@@ -42,13 +40,9 @@ MAN3= WWW::Search.3 \
.include <bsd.port.pre.mk>
-SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-
-PERL_MAJOR=${PERL_VER:C|^([1-9]+).*|\1|}
-PERL_MINOR=${PERL_VER:C|^[1-9]+\.0*([1-9]+).*|\1|}
-
-.if ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-.endif # ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
.include <bsd.port.post.mk>