aboutsummaryrefslogtreecommitdiff
path: root/www/p5-webservice-validator-html-w3c
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-12 05:35:20 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-12 05:35:20 +0000
commit3cb0b00e85b1a5d50c0b36adc19c7fc3103d05c4 (patch)
tree484c4b4cc7c9665e740ecb899fe4eb0a2d72aae9 /www/p5-webservice-validator-html-w3c
parent52b4c43ef3cc2b955496d92c73c3eddf40c04cc5 (diff)
New port
WebService::Validator::HTML::W3C provides access to the W3Cs online HTML validator. It's nothing to do with the W3C so pleas don't report any problems with it to them. Also, please use it wisely and don't abuse the W3Cs validator service. If you need to do a lot of validation consider downloading and installing the Validator on your own machine. WWW: http://search.cpan.org/dist/WebService-Validator-HTML-W3C/ PR: 87188 Submitted by: Toni Viemero <toni.viemero@iki.fi>
Notes
Notes: svn path=/head/; revision=145069
Diffstat (limited to 'www/p5-webservice-validator-html-w3c')
-rw-r--r--www/p5-webservice-validator-html-w3c/Makefile28
-rw-r--r--www/p5-webservice-validator-html-w3c/distinfo2
-rw-r--r--www/p5-webservice-validator-html-w3c/files/patch-Makefile.PL21
-rw-r--r--www/p5-webservice-validator-html-w3c/pkg-descr7
-rw-r--r--www/p5-webservice-validator-html-w3c/pkg-plist11
5 files changed, 69 insertions, 0 deletions
diff --git a/www/p5-webservice-validator-html-w3c/Makefile b/www/p5-webservice-validator-html-w3c/Makefile
new file mode 100644
index 000000000000..65609c4b7649
--- /dev/null
+++ b/www/p5-webservice-validator-html-w3c/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-WebService-Validator-HTML-W3C
+# Date created: Oct 10, 2005
+# Whom: toni.viemero@iki.fi
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebService-Validator-HTML-W3C
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WebService
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= Access to the W3Cs online HTML validator
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WebService::Validator::HTML::W3C::Error.3 \
+ WebService::Validator::HTML::W3C.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-webservice-validator-html-w3c/distinfo b/www/p5-webservice-validator-html-w3c/distinfo
new file mode 100644
index 000000000000..59344e8e0c33
--- /dev/null
+++ b/www/p5-webservice-validator-html-w3c/distinfo
@@ -0,0 +1,2 @@
+MD5 (WebService-Validator-HTML-W3C-0.1.tar.gz) = 1c3cf9659196a550608751ba26ac8c45
+SIZE (WebService-Validator-HTML-W3C-0.1.tar.gz) = 8919
diff --git a/www/p5-webservice-validator-html-w3c/files/patch-Makefile.PL b/www/p5-webservice-validator-html-w3c/files/patch-Makefile.PL
new file mode 100644
index 000000000000..273d973f762e
--- /dev/null
+++ b/www/p5-webservice-validator-html-w3c/files/patch-Makefile.PL
@@ -0,0 +1,21 @@
+--- Makefile.PL.orig Mon Oct 10 07:16:30 2005
++++ Makefile.PL Mon Oct 10 07:18:38 2005
+@@ -63,7 +63,8 @@
+ }
+
+ WriteMakefile
+- ('DISTNAME' => 'WebService-Validator-HTML-W3C',
++ ('NAME' => 'WebService::Validator::HTML::W3C',
++ 'DISTNAME' => 'WebService-Validator-HTML-W3C',
+ 'VERSION' => '0.03',
+ 'PL_FILES' => {},
+ 'PREREQ_PM' => {
+@@ -72,4 +73,8 @@
+ 'Test::More' => '0',
+
+ },
++ 'MAN3PODS' => {
++ 'lib/WebService/Validator/HTML/W3C/Error.pm' => 'blib/man3/WebService::Validator::HTML::W3C::Error.3',
++ 'lib/WebService/Validator/HTML/W3C.pm' => 'blib/man3/WebService::Validator::HTML::W3C.3',
++ },
+ );
diff --git a/www/p5-webservice-validator-html-w3c/pkg-descr b/www/p5-webservice-validator-html-w3c/pkg-descr
new file mode 100644
index 000000000000..9900748abe59
--- /dev/null
+++ b/www/p5-webservice-validator-html-w3c/pkg-descr
@@ -0,0 +1,7 @@
+WebService::Validator::HTML::W3C provides access to the W3Cs online HTML
+validator. It's nothing to do with the W3C so pleas don't report any problems
+with it to them. Also, please use it wisely and don't abuse the W3Cs
+validator service. If you need to do a lot of validation consider
+downloading and installing the Validator on your own machine.
+
+WWW: http://search.cpan.org/dist/WebService-Validator-HTML-W3C/
diff --git a/www/p5-webservice-validator-html-w3c/pkg-plist b/www/p5-webservice-validator-html-w3c/pkg-plist
new file mode 100644
index 000000000000..61440d0a33c8
--- /dev/null
+++ b/www/p5-webservice-validator-html-w3c/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/WebService/Validator/HTML/W3C/Error.pm
+%%SITE_PERL%%/WebService/Validator/HTML/W3C.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Validator/HTML/W3C/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Validator/HTML/W3C
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Validator/HTML
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Validator
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService
+@unexec rmdir %D/%%SITE_PERL%%/WebService/Validator/HTML/W3C 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WebService/Validator/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WebService/Validator 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WebService 2>/dev/null || true