aboutsummaryrefslogtreecommitdiff
path: root/www/pear-HTTP_Request/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-06 19:15:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-06 19:15:30 +0000
commit27de4c5c9cd2f878b6093ea35d3220bac6ae930e (patch)
treec735650c050c2222ac75177d0bf0beb99cc3720a /www/pear-HTTP_Request/Makefile
parent27f3d6050f8f8db80590c0043db846fba24d7524 (diff)
downloadports-27de4c5c9cd2f878b6093ea35d3220bac6ae930e.tar.gz
ports-27de4c5c9cd2f878b6093ea35d3220bac6ae930e.zip
Notes
Diffstat (limited to 'www/pear-HTTP_Request/Makefile')
-rw-r--r--www/pear-HTTP_Request/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/pear-HTTP_Request/Makefile b/www/pear-HTTP_Request/Makefile
new file mode 100644
index 000000000000..18a8f5a1c79b
--- /dev/null
+++ b/www/pear-HTTP_Request/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-HTTP_Request
+# Date created: 04 April 2004
+# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_Request
+PORTVERSION= 1.2
+CATEGORIES= www pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR classes providing an easy way to perform HTTP requests
+
+BUILD_DEPENDS= ${PEARDIR}/Net/URL.php:${PORTSDIR}/net/pear-Net_URL \
+ ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTTP
+FILES= Request.php Request/Listener.php
+EXAMPLES= download-progress.php example.php
+_EXAMPLESDIR= docs
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>