aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Services_Delicious
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-05 10:16:12 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-05 10:16:12 +0000
commit2bd0580765cff84a20bbd07e708f01c53fe05068 (patch)
treeb870f3a355ac4a0ae4de4c0614c1f573928c1329 /www/pear-Services_Delicious
parentb00122506e1464b533afefad4195d29e748c93b8 (diff)
downloadports-2bd0580765cff84a20bbd07e708f01c53fe05068.tar.gz
ports-2bd0580765cff84a20bbd07e708f01c53fe05068.zip
Notes
Diffstat (limited to 'www/pear-Services_Delicious')
-rw-r--r--www/pear-Services_Delicious/Makefile30
-rw-r--r--www/pear-Services_Delicious/distinfo3
-rw-r--r--www/pear-Services_Delicious/pkg-descr9
3 files changed, 42 insertions, 0 deletions
diff --git a/www/pear-Services_Delicious/Makefile b/www/pear-Services_Delicious/Makefile
new file mode 100644
index 000000000000..788aaff405e3
--- /dev/null
+++ b/www/pear-Services_Delicious/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-Services_Delicious
+# Date created: 2006/08/03
+# Whom: chinsan <chisnan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_Delicious
+PORTVERSION= 0.4.0
+CATEGORIES= www pear
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= PEAR Client for the del.icio.us web service
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_DOS2UNIX= yes
+
+CATEGORY= Services
+FILES= Delicious.php
+EXAMPLES= addPost.php config.php deletePost.php getDates.php getPosts.php \
+ getTags.php renameTag.php
+DOCS= api.txt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_Delicious/distinfo b/www/pear-Services_Delicious/distinfo
new file mode 100644
index 000000000000..81add1e29b09
--- /dev/null
+++ b/www/pear-Services_Delicious/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_Delicious-0.4.0.tgz) = a2d9c5811c10f7473f9a00e348d16aab
+SHA256 (PEAR/Services_Delicious-0.4.0.tgz) = 1bbdcf6b25b308e99f0ed16ece3699b8ebce8fb18ee8d288005b622e9ebe47d7
+SIZE (PEAR/Services_Delicious-0.4.0.tgz) = 5655
diff --git a/www/pear-Services_Delicious/pkg-descr b/www/pear-Services_Delicious/pkg-descr
new file mode 100644
index 000000000000..56dfb770ccb2
--- /dev/null
+++ b/www/pear-Services_Delicious/pkg-descr
@@ -0,0 +1,9 @@
+Services_Delicious is a client for the REST-based web service of del.icio.us.
+del.icio.us is a social bookmarks manager. It allows you to easily add sites
+you like to your personal collection of links, to categorize those sites
+with keywords, and to share your collection not only between your own
+browsers and machines, but also with others.
+Services_Delicious allows you to select, add and delete your bookmarks from
+any PHP script.
+
+WWW: http://pear.php.net/package/Services_Delicious