aboutsummaryrefslogtreecommitdiff
path: root/www/phpgedview/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 01:18:36 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 01:18:36 +0000
commitd6093ac397746e35c262b0d74ffac28aa67e84be (patch)
treedc503ddef60fb4c951e8d66b5501486d05761154 /www/phpgedview/Makefile
parent15ff72d2e3613804aab7744e655631f5a95e7001 (diff)
[MAINTAINER-UPDATE] www/phpGedView: update to 3.2.1
- Update to 3.2.1 Also: - move pre-install to post-extract - do not copy the -dist files to their real name but leave that as an exercise for the user. Otherwise it will clobber up the pkg-plist too much, which is created at install-time and thus doesn't have the nifty features like @unexec. PR: ports/75384 Submitted by: Alexander Novitsky <alecn2002@yandex.ru>
Notes
Notes: svn path=/head/; revision=124864
Diffstat (limited to 'www/phpgedview/Makefile')
-rw-r--r--www/phpgedview/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/phpgedview/Makefile b/www/phpgedview/Makefile
index 3483649294ce..3f43f565db1e 100644
--- a/www/phpgedview/Makefile
+++ b/www/phpgedview/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= phpGedView
-PORTVERSION= 3.1
+PORTVERSION= 3.2.1
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpgedview
+DISTNAME= ${PORTNAME}-${PORTVERSION}final
MAINTAINER= alecn2002@yandex.ru
COMMENT= Online genealogy viewer
@@ -22,7 +23,7 @@ NO_BUILD= yes
USE_MYSQL= yes
GEDVIEWDIR?= www/data/phpGedView
-FULLGWDIR= ${LOCALBASE}/${GEDVIEWDIR}
+FULLGWDIR= ${PREFIX}/${GEDVIEWDIR}
PLIST_SUB+= GEDVIEWDIR=${GEDVIEWDIR}
PLIST= ${WRKDIR}/pkg-plist
@@ -33,9 +34,9 @@ FILES_TO_DISTATE= authentication_index.php \
config_download.php \
config_gedcom.php
-pre-install:
+post-extract:
.for f in ${FILES_TO_DISTATE}
- ${CP} ${WRKSRC}/${f} ${WRKSRC}/${f}-dist
+ ${MV} ${WRKSRC}/${f} ${WRKSRC}/${f}-dist
.endfor
${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?%%GEDVIEWDIR%%?g" >${PLIST}
${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm %%GEDVIEWDIR%%?g" >> ${PLIST}
@@ -45,7 +46,7 @@ do-install:
${CP} -Rnv ${WRKSRC}/* ${FULLGWDIR}
${FIND} ${FULLGWDIR} -type d -exec ${CHMOD} a+x {} \;
.for f in ${FILES_TO_DISTATE}
- ${CHMOD} a+w ${FULLGWDIR}/${f}
+ ${CHMOD} a+w ${FULLGWDIR}/${f}-dist
.endfor
${CHMOD} a+w ${FULLGWDIR}/index