aboutsummaryrefslogtreecommitdiff
path: root/www/phpscheduleit
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-08-18 14:29:08 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-08-18 14:29:08 +0000
commit63f3e3b0d43bb0b1197cbb5e4c4dfc3a34adb25b (patch)
treedb78183546bb8049f66df049872ab54fe9939c31 /www/phpscheduleit
parentdd195ccb65e4fa43789bd6207b16edef95e01297 (diff)
downloadports-63f3e3b0d43bb0b1197cbb5e4c4dfc3a34adb25b.tar.gz
ports-63f3e3b0d43bb0b1197cbb5e4c4dfc3a34adb25b.zip
Notes
Diffstat (limited to 'www/phpscheduleit')
-rw-r--r--www/phpscheduleit/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/phpscheduleit/Makefile b/www/phpscheduleit/Makefile
index 9bf8fb15830f..3198c913957b 100644
--- a/www/phpscheduleit/Makefile
+++ b/www/phpscheduleit/Makefile
@@ -28,20 +28,21 @@ PKGMESSAGE= ${WRKDIR}/${PORTNAME}/pkg-message
SUB_FILES= pkg-message
PLIST_DIRSTRY= %%WWWDIR%%
-OPTIONS= POSTGRE "Use PostgreSQL Database" off \
- APACHE "Use Apache webserver" on \
- LIGHTTPD "Use Lighttpd webserver" off
+OPTIONS_DEFINE= PGSQL APACHE LIGHTTPD
+OPTIONS_DEFAULT=APACHE
.include <bsd.port.options.mk>
-.if defined(WITH_POSTGRE)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
.endif
-.if defined(WITH_APACHE)
-USE_APACHE= 22
+
+.if ${PORT_OPTIONS:MAPACHE}
+USE_APACHE_RUN= 22
.endif
-.if defined(WITH_LIGHTTPD)
+
+.if ${PORT_OPTIONS:MLIGHTTPD}
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
.endif