aboutsummaryrefslogtreecommitdiff
path: root/www/plasma5-plasma-browser-integration/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-27 20:29:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-27 20:29:36 +0000
commitef944cd3535703c6f81803ea9c79523d18bf2c5a (patch)
tree59ff42fd6dd4aeb0189ec1ae805c13207a7bb391 /www/plasma5-plasma-browser-integration/Makefile
parent3ccba726e98b92146ad0a4158dd028c2f05b5d00 (diff)
Import the KDE Plasma5 ports
This is an import of the Plasma5 ports that we have had in the development repository for quite some time now. Please note: * Plasma5 cannot be installed at the same time as KDE SC4. * Qt5 assumes /etc/localtime to be a symlink to a tz file, not a regular file. * To start plasma5, it is recommended to use something like exec ck-launch-session startkde * Powermanagement and such is not working :-) I would like to thank all the people that have helped test it in the past years. Reviewed by: adridg Differential Revision: https://reviews.freebsd.org/D15096
Notes
Notes: svn path=/head/; revision=468495
Diffstat (limited to 'www/plasma5-plasma-browser-integration/Makefile')
-rw-r--r--www/plasma5-plasma-browser-integration/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/www/plasma5-plasma-browser-integration/Makefile b/www/plasma5-plasma-browser-integration/Makefile
new file mode 100644
index 000000000000..97215c5c801e
--- /dev/null
+++ b/www/plasma5-plasma-browser-integration/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= plasma-browser-integration
+DISTVERSION= 5.10.95.20181011
+CATEGORIES= www kde
+PKGNAMEPREFIX= plasma5- # this port is not yet using CATEGORIES=kde-plasma
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Plasma5 components to integrate browsers into the desktop
+
+USES= cmake:outsource kde:5
+USE_KDE= activities config coreaddons i18n kio notifications package \
+ plasma-framework runner service windowsystem
+USE_QT5= core dbus gui widgets \
+ buildtools_build qmake_build
+USE_GITHUB= yes
+GH_ACCOUNT= KDE
+GH_TAGNAME= c593654
+
+.include <bsd.port.mk>