aboutsummaryrefslogtreecommitdiff
path: root/www/py-amf
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-19 20:06:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-19 20:06:40 +0000
commitf896371ff3c1df00c4ac86678bfce1f623c35179 (patch)
tree8562c63262d38640ea2c4d952ece9c6f1a916f4a /www/py-amf
parent33a338be61064e5528d91e44ada1f1b972568acc (diff)
downloadports-f896371ff3c1df00c4ac86678bfce1f623c35179.tar.gz
ports-f896371ff3c1df00c4ac86678bfce1f623c35179.zip
Notes
Diffstat (limited to 'www/py-amf')
-rw-r--r--www/py-amf/Makefile37
-rw-r--r--www/py-amf/distinfo3
-rw-r--r--www/py-amf/pkg-descr17
-rw-r--r--www/py-amf/pkg-plist250
4 files changed, 307 insertions, 0 deletions
diff --git a/www/py-amf/Makefile b/www/py-amf/Makefile
new file mode 100644
index 000000000000..0fd106cf892b
--- /dev/null
+++ b/www/py-amf/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: py-amf
+# Date created: 14 July 2008
+# Whom: Junji NAKANISHI <jun-g@daemonfreaks.com>
+#
+# $FreeBSD$
+
+PORTNAME= amf
+PORTVERSION= 0.3.1
+CATEGORIES= www devel python
+MASTER_SITES= http://download.pyamf.org/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PYDISTUTILS_PKGNAME}-${PORTVERSION}
+
+MAINTAINER= jun-g@daemonfreaks.com
+COMMENT= AMF support for Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= PyAMF
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/ ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 250
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/uuid.py:${PORTSDIR}/devel/py-uuid
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/fpconst.py:${PORTSDIR}/math/py-fpconst
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/py-amf/distinfo b/www/py-amf/distinfo
new file mode 100644
index 000000000000..efab80aa897b
--- /dev/null
+++ b/www/py-amf/distinfo
@@ -0,0 +1,3 @@
+MD5 (PyAMF-0.3.1.tar.gz) = 88597930a95dc112ce39359521d43f3d
+SHA256 (PyAMF-0.3.1.tar.gz) = dc3b0c653750f603c2d0e034b76404943b89d57a5ed80af462eb115743d66e79
+SIZE (PyAMF-0.3.1.tar.gz) = 1014888
diff --git a/www/py-amf/pkg-descr b/www/py-amf/pkg-descr
new file mode 100644
index 000000000000..27fc98ecbdfe
--- /dev/null
+++ b/www/py-amf/pkg-descr
@@ -0,0 +1,17 @@
+PyAMF provides Action Message Format (AMF) support for Python that is
+compatible with the Flash Player.
+
+The Adobe Integrated Runtime and Flash Player use AMF to communicate between
+an application and a remote server. AMF encodes remote procedure calls (RPC)
+into a compact binary representation that can be transferred over HTTP/HTTPS
+or the RTMP/RTMPS protocol. Objects and data values are serialized into this
+binary format, which increases performance, allowing applications to load data
+up to 10 times faster than with text-based formats such as XML or SOAP.
+
+AMF3, the default serialization for ActionScript 3.0, provides various
+advantages over AMF0, which is used for ActionScript 1.0 and 2.0. AMF3 sends
+data over the network more efficiently than AMF0. AMF3 supports sending int
+and uint objects as integers and supports data types that are available only
+in ActionScript 3.0, such as ByteArray, ArrayCollection, and IExternalizable.
+
+WWW: http://pyamf.org/
diff --git a/www/py-amf/pkg-plist b/www/py-amf/pkg-plist
new file mode 100644
index 000000000000..6cd6300c469a
--- /dev/null
+++ b/www/py-amf/pkg-plist
@@ -0,0 +1,250 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PORTDOCS%%%%DOCSDIR%%/api/api-objects.txt
+%%PORTDOCS%%%%DOCSDIR%%/api/bug-index.html
+%%PORTDOCS%%%%DOCSDIR%%/api/class-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/api/crarr.png
+%%PORTDOCS%%%%DOCSDIR%%/api/epydoc.css
+%%PORTDOCS%%%%DOCSDIR%%/api/epydoc.js
+%%PORTDOCS%%%%DOCSDIR%%/api/frames.html
+%%PORTDOCS%%%%DOCSDIR%%/api/help.html
+%%PORTDOCS%%%%DOCSDIR%%/api/identifier-index.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index.html
+%%PORTDOCS%%%%DOCSDIR%%/api/module-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.ASObject-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.BaseContext-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.BaseDecoder-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.BaseEncoder-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.BaseError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.ClassAlias-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.ClassMetaData-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.ClientTypes-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.CustomTypeFunc-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.DecodeError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.EOStream-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.EncodeError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.MixedArray-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.ReferenceError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.UnknownClassAlias-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.adapters-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.adapters-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.adapters.PackageImporter-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.adapters._django_db_models_query-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.adapters._django_db_models_query-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.adapters._google_appengine_ext_db-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.adapters._google_appengine_ext_db-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf0-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf0-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf0.ASTypes-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf0.Context-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf0.Decoder-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf0.Encoder-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf0.RecordSet-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.ASTypes-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.ByteArray-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.ClassDefinition-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.Context-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.DataInput-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.DataOutput-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.Decoder-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.Encoder-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.amf3.ObjectEncoding-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.ArrayCollection-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.ObjectProxy-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.data-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.data-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.data.DataErrorMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.data.DataMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.data.PagedMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.data.SequencedMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.messaging-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.messaging-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.messaging.AbstractMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.messaging.AcknowledgeMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.messaging.AsyncMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.messaging.CommandMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.messaging.ErrorMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.flex.messaging.RemotingMessage-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.logging-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.logging-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.BaseFault-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.Envelope-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.ErrorFault-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.HeaderCollection-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.Message-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.RemotingCallFailed-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.RemotingError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.Request-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.Response-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.amf0-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.amf0-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.amf0.RequestProcessor-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.amf3-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.amf3-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.amf3.BaseServerError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.amf3.RequestProcessor-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.amf3.ServerCallFailed-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.client-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.client-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.client.RemotingService-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.client.RequestWrapper-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.client.ServiceMethodProxy-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.client.ServiceProxy-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.BaseGateway-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.BaseServiceError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.InvalidServiceMethodError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.ServiceCollection-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.ServiceRequest-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.ServiceWrapper-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.UnknownServiceError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.UnknownServiceMethodError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.django-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.django-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.django.DjangoGateway-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.google-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.google-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.google.WebAppGateway-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.twisted-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.twisted-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.twisted.AMF0RequestProcessor-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.twisted.AMF3RequestProcessor-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.twisted.TwistedGateway-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.wsgi-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.wsgi-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.remoting.gateway.wsgi.WSGIGateway-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.sol-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.sol-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.sol.SOL-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.BufferedByteStream-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.DataTypeMixIn-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.NetworkIOMixIn-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.StringIOProxy-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.imports-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.imports-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.imports.AlreadyRead-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.imports.LazyModule-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/pyamf.util.imports.SubModuleLoadHook-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/redirect.html
+%%PORTDOCS%%%%DOCSDIR%%/api/since-index.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-everything.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.adapters-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.adapters._django_db_models_query-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.adapters._google_appengine_ext_db-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.amf0-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.amf3-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.flex-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.flex.data-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.flex.messaging-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.logging-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting.amf0-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting.amf3-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting.client-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting.gateway-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting.gateway.django-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting.gateway.google-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting.gateway.twisted-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.remoting.gateway.wsgi-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.sol-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.util-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc-pyamf.util.imports-module.html
+%%PORTDOCS%%%%DOCSDIR%%/api/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/api/twisted.web.resource.IResource-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ad.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_2.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_3.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_4.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_5.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_6.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_7.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_8.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_9.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_10.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_am_11.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_as.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ba.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ba_2.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ba_3.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ba_4.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ba_5.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_cl.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_cl_2.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_cu.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_de.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_en.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_eo.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_2.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_3.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_4.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_5.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_6.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_7.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_8.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_9.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_10.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_11.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_12.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_fl_13.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_mi.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_2.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_3.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_4.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_5.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_6.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_7.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_8.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_9.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_10.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_11.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_12.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_13.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_14.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_15.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_16.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_17.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_18.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_19.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_20.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_21.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_22.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_23.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_24.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_25.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_26.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_27.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_28.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_29.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_30.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_31.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_32.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_33.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_34.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_35.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_re_36.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_so.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_un.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ut.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ut_2.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ut_3.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ut_4.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ut_5.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ut_6.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_pyamf_ut_7.gif
+%%PORTDOCS%%%%DOCSDIR%%/api/uml_class_diagram_for_twisted_.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/api
+%%PORTDOCS%%@dirrm %%DOCSDIR%%