aboutsummaryrefslogtreecommitdiff
path: root/www/py-django/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-31 06:50:11 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-31 06:50:11 +0000
commita6e103ae4cffa5b986b9c9798324679b708226d3 (patch)
treeb44132b3fee382d90b4ce4d541bed28eb88c5483 /www/py-django/Makefile
parent60659023950bad84142bf654506bb8b2fea2234f (diff)
downloadports-a6e103ae4cffa5b986b9c9798324679b708226d3.tar.gz
ports-a6e103ae4cffa5b986b9c9798324679b708226d3.zip
Notes
Diffstat (limited to 'www/py-django/Makefile')
-rw-r--r--www/py-django/Makefile18
1 files changed, 3 insertions, 15 deletions
diff --git a/www/py-django/Makefile b/www/py-django/Makefile
index ad37e28fe7cb..27cda54e24df 100644
--- a/www/py-django/Makefile
+++ b/www/py-django/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME?= django
-PORTVERSION?= 0.95.1
-PORTREVISION?= 1
+PORTVERSION?= 0.96
CATEGORIES= www python
-MASTER_SITES?= http://media.djangoproject.com/releases/${PORTVERSION:R}/
+MASTER_SITES?= http://media.djangoproject.com/releases/${PORTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Django-${PORTVERSION}
DIST_SUBDIR= python
@@ -17,23 +16,12 @@ DIST_SUBDIR= python
MAINTAINER?= python@FreeBSD.org
COMMENT= High-level Python Web framework
-BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
USE_GETTEXT= yes
-USE_PYTHON= 2.3+
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
-EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
-
DOCSDIR= ${PREFIX}/share/doc/py-django
-PYDJANGO_EGG= Django-${PORTVERSION}-py${PYTHON_VER}.egg
-
-PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
- PYDJANGO_EGG=${PYDJANGO_EGG} \
- PYDJANGO_EGG_VER="Django==${PORTVERSION}"
-
OPTIONS= MOD_PYTHON3 "Install Apache2 with mod_python3" off \
POSTGRESQL "PostgreSQL support" off \
MYSQL "MySQL support" off \