aboutsummaryrefslogtreecommitdiff
path: root/www/py-fastapi
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2023-01-11 13:34:10 +0000
committerWen Heping <wen@FreeBSD.org>2023-01-11 13:34:10 +0000
commit98793bba5887606bf009a09ac802bd0a3ce9e78c (patch)
treed4d667e7d3c4b09e1842830e622a3e739b559bc3 /www/py-fastapi
parent2d50a041d7640066e9071e16f7c7e33ed967b0e7 (diff)
downloadports-98793bba5887606bf009a09ac802bd0a3ce9e78c.tar.gz
ports-98793bba5887606bf009a09ac802bd0a3ce9e78c.zip
www/py-fastapi: Update to 0.89.1
Diffstat (limited to 'www/py-fastapi')
-rw-r--r--www/py-fastapi/Makefile7
-rw-r--r--www/py-fastapi/distinfo6
-rw-r--r--www/py-fastapi/files/patch-setup.py76
3 files changed, 7 insertions, 82 deletions
diff --git a/www/py-fastapi/Makefile b/www/py-fastapi/Makefile
index 402c62959a7e..743ee454e46a 100644
--- a/www/py-fastapi/Makefile
+++ b/www/py-fastapi/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fastapi
-PORTVERSION= 0.81.0
+PORTVERSION= 0.89.1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +11,13 @@ WWW= https://github.com/tiangolo/fastapi
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pydantic>=1.6.2:devel/py-pydantic@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}starlette>=0.19.1:www/py-starlette@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}starlette>=0.22:www/py-starlette@${PY_FLAVOR}
USES= cpe python:3.7+
CPE_VENDOR= ${PORTNAME}_project
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/www/py-fastapi/distinfo b/www/py-fastapi/distinfo
index 2938a03da1d9..ea225779464c 100644
--- a/www/py-fastapi/distinfo
+++ b/www/py-fastapi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1661740862
-SHA256 (fastapi-0.81.0.tar.gz) = 9dafdc41feda85ee5acf0f7dd6bcb7fd946318a6664b41fd33e33b26f666a346
-SIZE (fastapi-0.81.0.tar.gz) = 9667083
+TIMESTAMP = 1673443485
+SHA256 (fastapi-0.89.1.tar.gz) = 15d9271ee52b572a015ca2ae5c72e1ce4241dd8532a534ad4f7ec70c376a580f
+SIZE (fastapi-0.89.1.tar.gz) = 9702353
diff --git a/www/py-fastapi/files/patch-setup.py b/www/py-fastapi/files/patch-setup.py
deleted file mode 100644
index 658be69cc8a3..000000000000
--- a/www/py-fastapi/files/patch-setup.py
+++ /dev/null
@@ -1,76 +0,0 @@
---- setup.py.orig 2022-02-18 00:15:19 UTC
-+++ setup.py
-@@ -0,0 +1,73 @@
-+#!/usr/bin/env python
-+# setup.py generated by flit for tools that don't yet use PEP 517
-+
-+from distutils.core import setup
-+
-+packages = \
-+['fastapi',
-+ 'fastapi.dependencies',
-+ 'fastapi.middleware',
-+ 'fastapi.openapi',
-+ 'fastapi.security']
-+
-+package_data = \
-+{'': ['*']}
-+
-+install_requires = \
-+['starlette ==0.17.1',
-+ 'pydantic >=1.6.2,!=1.7,!=1.7.1,!=1.7.2,!=1.7.3,!=1.8,!=1.8.1,<2.0.0']
-+
-+extras_require = \
-+{'all': ['requests >=2.24.0,<3.0.0',
-+ 'jinja2 >=2.11.2,<4.0.0',
-+ 'python-multipart >=0.0.5,<0.0.6',
-+ 'itsdangerous >=1.1.0,<3.0.0',
-+ 'pyyaml >=5.3.1,<6.0.0',
-+ 'ujson >=4.0.1,<5.0.0',
-+ 'orjson >=3.2.1,<4.0.0',
-+ 'email_validator >=1.1.1,<2.0.0',
-+ 'uvicorn[standard] >=0.12.0,<0.16.0'],
-+ 'dev': ['python-jose[cryptography] >=3.3.0,<4.0.0',
-+ 'passlib[bcrypt] >=1.7.2,<2.0.0',
-+ 'autoflake >=1.4.0,<2.0.0',
-+ 'flake8 >=3.8.3,<4.0.0',
-+ 'uvicorn[standard] >=0.12.0,<0.16.0'],
-+ 'doc': ['mkdocs >=1.1.2,<2.0.0',
-+ 'mkdocs-material >=8.1.4,<9.0.0',
-+ 'mdx-include >=1.4.1,<2.0.0',
-+ 'mkdocs-markdownextradata-plugin >=0.1.7,<0.3.0',
-+ 'typer-cli >=0.0.12,<0.0.13',
-+ 'pyyaml >=5.3.1,<6.0.0'],
-+ 'test': ['pytest >=6.2.4,<7.0.0',
-+ 'pytest-cov >=2.12.0,<4.0.0',
-+ 'mypy ==0.910',
-+ 'flake8 >=3.8.3,<4.0.0',
-+ 'black ==21.9b0',
-+ 'isort >=5.0.6,<6.0.0',
-+ 'requests >=2.24.0,<3.0.0',
-+ 'httpx >=0.14.0,<0.19.0',
-+ 'email_validator >=1.1.1,<2.0.0',
-+ 'sqlalchemy >=1.3.18,<1.5.0',
-+ 'peewee >=3.13.3,<4.0.0',
-+ 'databases[sqlite] >=0.3.2,<0.6.0',
-+ 'orjson >=3.2.1,<4.0.0',
-+ 'ujson >=4.0.1,<5.0.0',
-+ 'python-multipart >=0.0.5,<0.0.6',
-+ 'flask >=1.1.2,<3.0.0',
-+ 'anyio[trio] >=3.2.1,<4.0.0',
-+ 'types-ujson ==0.1.1',
-+ 'types-orjson ==3.6.0'],
-+ "test:python_version<'3.7'": ['types-dataclasses ==0.1.7']}
-+
-+setup(name='fastapi',
-+ version='0.74.0',
-+ description='FastAPI framework, high performance, easy to learn, fast to code, ready for production',
-+ author='Sebastián Ramírez',
-+ author_email='tiangolo@gmail.com',
-+ url='https://github.com/tiangolo/fastapi',
-+ packages=packages,
-+ package_data=package_data,
-+ install_requires=install_requires,
-+ extras_require=extras_require,
-+ python_requires='>=3.6.1',
-+ )