aboutsummaryrefslogtreecommitdiff
path: root/www/py-formalchemy/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2010-07-18 13:30:18 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2010-07-18 13:30:18 +0000
commitc52fa83a3c6265ab50bdf0277fe20faf33fccfd0 (patch)
treee9d18dcd34ca54474f347f841534f16bbc75d3ba /www/py-formalchemy/Makefile
parent5860152733437353401ca05a667ff4da1738b4b9 (diff)
Notes
Diffstat (limited to 'www/py-formalchemy/Makefile')
-rw-r--r--www/py-formalchemy/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/py-formalchemy/Makefile b/www/py-formalchemy/Makefile
new file mode 100644
index 000000000000..24295afee795
--- /dev/null
+++ b/www/py-formalchemy/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-formalchemy
+# Date created: 13 April 2010
+# Whom: ghostonthewire <ghostonthewire at gmail dot com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= formalchemy
+PORTVERSION= 1.3.3
+CATEGORIES= www python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= FormAlchemy-${DISTVERSION}
+
+MAINTAINER= ghostonthewire@gmail.com
+COMMENT= Toolkit for creating HTML form elements manually or from SQLAlchemy mapped classes
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.4.5:${PORTSDIR}/databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}Tempita>=0.4:${PORTSDIR}/textproc/py-Tempita/ \
+ ${PYTHON_PKGNAMEPREFIX}webhelpers>=0.6.4:${PORTSDIR}/www/py-webhelpers/
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= FormAlchemy
+PYDISTUTILS_NOEGGINFO= yes
+
+.include <bsd.port.mk>